Help me find variables.txt

Mac Technical Support
I feel like I've read all the threads related to this matter yet I still can't find the file. I've unhidden all my files and looked everywhere.

This is OSX 10.6.8 Snow leopard. I want to edit variables.txt to reduce my framerate to make my mac run cooler. Thanks for any help you guys can offer.

K
Try doing this and see if it helps.

    1. Click anywhere on your Desktop.
    2. Select Go from the system menu bar and select Go to Folder: http://i50.tinypic.com/28vt2yw.png
    3. Copy/Paste the following line:
    ~/Library/Application Support/Blizzard/StarCraft II4. Press enter and you should now see your variables.txt files.

I hope that helps.
First, thanks for your help. I tried what you recommended and it says the folder can't be found. The Blizzard folder doesn't even exist in Application support.

On a related note, none of my settings save, so I have to reinput them every time I open the game.
That is strange. This may mean it is has permission problems creating the directory to save the files.

Can you run a permissions repair and see if this helps?

Resetting permissions on the Starcraft II folder
    1. Select the Starcraft II folder
    2. Press Command + I
    3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
    4. Make sure you have Read & Write permissions
    5. Click on the Burst icon (cog wheel) and select Apply to enclosed items

Repair Permissions via Disk Utility
    1. Navigate to /Applications/Utilities/ and open Disk Utility.
    2. Select the hard drive the game is installed on.
    3. Select the First Aid option.
    4. Click on the Repair Disk Permissions button.
Well I tried that, nothing seems to have changed.
Do you happen to have even just the Application Support folder there?
Like I mentioned before, there is no Blizzard folder in Application support. If you were asking if the folder Application Support is there, yes it is.
how about for windows 7?
when i open my starcraft II file the only available variable files i see are Variables and EditorVariables (Notepad)
I open these files and its just a list of settings and graphics.
i tried inserting localeidassets=enUS localeiddata=enUS into these files but it still doesn't work
i also tried using the search box and type variable.txt but got nothing too.
Please help. Thanks
bump
@CrossEnke- You'll need to go post in the Windows forums for any Windows solutions: http://us.battle.net/sc2/en/forum/13438/

@MisterWiggle- I'm still thinking it is a permission issue. Try this simple test.



This should see if the issue is related to permissions in your current user account.
Nice, that did the trick. I wonder why my permissions aren't correct for this account?
Actually for me it was in : ~/Users/yourusername/Library/Application Support/Blizzard/StarCraft II
http://www.youtube.com/watch?v=a_lGz5_Ra5Q
watch that it will help

http://www.youtube.com/watch?v=a_lGz5_Ra5Q

http://www.youtube.com/watch?v=a_lGz5_Ra5Q

http://www.youtube.com/watch?v=a_lGz5_Ra5Q

Join the Conversation

Return to Forum