Blank screen after logging in

Technical Support
So I switched back to SEA server today,then after switching the client back onto USA, I did the PW and authentication business as usual, but after entering those 2 details, I am stuck at the log in screen, and the usual box that flashes authenticating and initializing doesn't appear.
Yes, so I'm having the exact same problem and I didn't even switch anything. Kind of weird considering I was up semi late playing the game and it doesn't let me login when I wake up in the morning. It just stays at the page where the spaceship flies away, and like you said, no authenticating or initializing boxes appear. I'll camp this topic in hopes for an answer.
Same problem here, haven't switched anything either. If I do play as guest the main screen loads fine but logging in just give me a blank screen with back as the only option
same, just gives me the back button and no loggin
Same here.
So it IS multiple people, maybe bliz is doing something?
Same issue here. I can login on my other account, but, I can't play on the ladder. I get some error message.
Same here. It's pissing me off.
same here...
This is frustrating, random in occurrence but without a repair option helpless to address the bizarre issue. Load screen "freezes" (game does not crash, but is in the purgatory of loading into b.net). This has happened to me multiple times, please address in next patch or sooner!!

Thanks.
Same as well... Just a blank screen with the "back" button on the bottom left.
yes im suffering from the same problem for no apparent reason

"Same as well... Just a blank screen with the "back" button on the bottom left."

please help cannot play at all
I get a blank screen that just has the Back button after i login.
Same here, Kmilz.
Suddenly working for me now. Although I *did* reinstall and delete cache.
https://us.battle.net/support/en/article/deleting-the-battlenet-cache-folder-pc
Same thing here. Anyone else get it to clear yet?
The same thing is happening to me, it just shows a blank screen and a back button after I login
same problem...
Tried clearing cache. no luck. Cannot login as guest either

Join the Conversation

Return to Forum