Version of SC2 required is unavailable...

Mac Technical Support
"The version of StarCraft II required to play this game is unavailable."

I can't play a mission that I paid for with Wings of Liberty? I'm just trying to play the Echoes of the Future mission. Which I could have played not more than a week ago. With the game I bought. I'm confused.

Also, on a Mac.
Can you take a screenshot of this error? I can investigate this. Thanks!
Were you online at the time? I believe offline play is isn't working at the moment.
10/15/2012 11:46 AMPosted by Machkhan
Can you take a screenshot of this error? I can investigate this. Thanks!


I believe he's talking about this stupid little message that pops up when you start the game in OFFLINE mode with no internet connection. I too need the offline mode as I don't always have a connection. Here's a screenshot of the message: http://i.imgur.com/7puPX.jpg
I am getting the same thing. for three different missions. They are the Thor, ?, Siege tank missions. Here is a screen shot of the error message. It occurs after the cinema scenes before the mission is loaded. http://i.imgur.com/nQaA1.png
Thanks.

Can you try this and see if it helps?

Repairing StarCraft II
    1. Navigate to /Applications/StarCraft II/Battle.net
    2. Delete the Battle.net.MPQ file
    3. Launch StarCraft II

This will force the game to see it is missing data and self repair.
Thank You! That fixed the problem. I launched, pressed play, and then downloaded the missing files.
Awesome!
I just navigated to C:\StarCraft II and there is no Battle.net folder.
http://imgur.com/DZP3k
You're in the wrong folder. That screenshot shows your documents folder.
So I removed battlenet.mpq and it didnt resolve itself it just made the problem worse. Now When i get to the loggin page it doesnt get past the loggin it can't connect to battlenet. It gets stuck at connecting to battlenet. Helpp!! Thank you :)
Did you try running repair to see if it helps?
when on a mac just use spotlight to find it it is easy and then you will need to up date and it still may not work
You have to have an internet connection to repair. What happens when I want to play offline because I am travelling, don't have a connection, and it won't let me play? This is unacceptable. For such a "high quality" game and "reputable" company, these kinds of things really shouldn't be happening. If I pay $50 for a game, I would expect to be able to play that game anytime and anywhere I want to. I think I will just stick with Steam for all my games. They have never let me down since they first came up.
This is a known issue. It will be addressed in a future update.
@Blizz_Programmers

If you're busy trying to fix it the hard way, I feel like this could easily be hot-fixed with a simple script that when the little error dialog pops up, a second button is there next to "OK" called "REPAIR" or something, that just restarts the game and deletes the MPQ.

EDIT:
Also, to the gentlemen with the entitled attitudes, I would recommend you exercise more care and empathy in your dealings with people.
also having issues with ofline play, can do custom games just fine but cant do campain....annoying!!!!
o ya and i did suggested fix bolth of them and still no joy.

didnt have issue untill it forced me to patch
I had the same problem and this worked perfectly.
i have the same exact problem. I implement the fix and it only works for a set amount of time. i.e.. i fixed it last night was able to play offline for a while with no problems (played several levels) then today i have to delete the file again and repair again. Please issue a sustainable resolution.

Join the Conversation

Return to Forum