Game not launching

Technical Support
So i click on the starcraft 2 .exe and the game starts as usual. then i click play on the launcher and nothing happens........ if i try to launch again it says that starcraft 2 is already running...... help please!
FuzzNuts, another program may be interfering with StarCraft II. I'd try a Selective Startup, and see how that goes.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
im having the same problem. I downloaded starcraft 2, hit play when it was 100% complete, nothing happened. My mouse cursor indicated the computer was trying to start up the game. When i try to load another instance of sc2, nothing would happen. no error messages. i had to go to the task manager and manually close sc2.exe. there was something else running called sc2switcher? when i manually closed it it said, "an error occured starting Starcraft II. Please try again."

ive tried ur link above velnrak. i've also re-installed and gone through https://us.battle.net/support/en/article/lockups-and-general-crash-errors-pc-26260?utm_source=internal&utm_medium=support_forums&utm_campaign=BlizzardCS. Suggestions please.
I am having the same issues. Ive reinstalled multiple times on to both my HDD and SSD but no dice. I also tried Velnrak's link but I did not fix the problem.
I am having the same issue, tried system restores, tried reinstalling. None of my blizzard games will launch at all. Tried the link, does not work.
Let's also try deleting the Battle.net cache, as well as the Blizzard Entertainment folder.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
i forgot to mention those two. i did those too and still not working
I also did both of these and it's not working either. I managed to reinstall the game via my CDs, the game installs fine but won't patch properly. I believe it's an issue with the updater but beyond that am lost.
Just to be thorough, I would try each of these steps.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
i tried most of that list... i give up. btw, diablo 3 works fine.
I am having the same issue, was this ever resolved? I have tried all the basic tips for troubleshooting the launcher.
I just installed SC2 on a new PC after not playing for 2 years and had the same issue as the OP. Clicking 'Play' on launcher and nothing happens.

I found something at GameFAQs forum which worked:
I disabled the GPU virtulisation option from Virtu MVP (came with AsRock motherboard) and it worked fine.
Link: (scroll to bottom) http://www.gamefaqs.com/boards/939643-starcraft-ii-wings-of-liberty/64729807

Good luck!
WOW... THEOSYMPHANY. You're my freakin hero. it worked!!!! thanks so much!!!!
it is the virtual MVP
I'm having the same problem, I deavtivated Virtual MVP, I've made attempts the uninstall the program but it wont uninstall. I've tried all the steps above to no success. Help me please.

EDIT: Virtu MVP Fully removed from my computer, Still cant open SC2.
If someone has this mother board this has to be the problem cause this fixed it thank you
Had this same problem. Disabling/Uninstalling Virtu MVP fixed the problem.
when i clicking starcraft 2 i see the checking of updates and nothing more so the game is not launching please help me
when i clicking starcraft 2 i see the checking of updates and nothing more so the game is not launching please help me
What have you tried so far, ARMAN? I would start with this step.
________________________________________________
Rate me! https://www.surveymonkey.com/s/Velnrak

Join the Conversation

Return to Forum