Starcraft II WoL won't optimize.

Technical Support
I decided to play SC2 again after a while to get ready for HoTS, so I installed the game and was brought to the SC2 patcher window. It said something like applying or downloading patch 1 out of 24, and after downloading the first patch it took me to the SC2 installation optimizer screen.

It refuses to budge past 0.0%, with the exception of twice it's gone to 0.1% before it goes totally dormant. I've tried running the game as admin, disabling my firewall, and re-installing the game game yet again but to no avail, and rebooting my PC. My internet connection is working fine, Here's my specs:

Windows 8 Pro x64
Nvidia GTX 550 TI (1 GB DDR5)

If you need any other specs, let me know. Thanks in advance for any help.
I know this went unanswered but I'm running into the same situation. Won't go past .1 or 0% on the optimizing screen. Any ideas on how to fix it?
I'd try these ideas, MetaMegaRH, and work from there.
Monday - Friday, 8 am - 5 pm PST
I found some stuff on google suggesting to use a windoes compatability thing and it worked. Right clicked the starcraft.exe and set it to windows 7 service pack or something like that. Ran it as administrator and it worked. Just got the new laptop last night and windows 8 is a whole new ball game to me.

Join the Conversation

Return to Forum