Unable to download authentication module

Mac Technical Support
I can't seem to log in. When I click login, I get the message "Unable to download authentication module". What should I do?
Try removing the Battle.net cache and try again.
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help? https://battle.net/support/article/contact
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
No, that didn't help. :(
Says: Battlenet connection lost
Unable to download authentication module.
I should probably mention, this is on the HOTS Beta. Normal SC works just fine.
I'm having the same problem. And I tried removing the Battle.net cache.
i have the same problem, anyone know a fix?
Is this for the live version of the game or beta?
I'm having troubles with the beta.
You will need to post in the beta forums for assistance. Technical Support is unable to address beta issues.

Same issue.. but this is on SC WoL, my HoTS works just fine.
Have you tried the mentioned solution above and delete the Battle.net cache?
Yeah, I'm having the same problem. I have two laptops that cannot connect. I just have the WoL, not the new beta yet. And all of a sudden, yesterday (Jan 3) it stopped working after working fine for a year. I've deleted the cache, but there is still no change.
I'm on a US account, but I'm in Japan now.
I can not even seem to get to the point of entering my password anymore since I deleted the battle.net cache! it just keeps saying connecting to battle.net....I just wanna play the HotS beta mannnnn any suggestions?...
I'm having the same issue as well from Japan. I have tried reinstalling the application, deleting battle.net cache but they didn't help :(
Is this issue still happening?

From what I've read, it may be a DNS issue. Can we try flushing your DNS first and see if it helps.

Flush the DNS
    1. Navigate to /Applications/Utilities/ and launch Terminal.
    2. Copy/Paste the following:
    dscacheutil -flushcache3. Press return.
    Note: You will not get any feedback from Terminal if this is done correctly on any OS.
    4. Then go in your Network pref pane => Advanced and click "Renew DHCP lease"
    5. Attempt to connect to the game.
I tried flushing the DNS but I am still having the same issue :/ I am on a mac...and my wings of liberty loads launches and plays just fine....but the heart of the swarm beta just refuses to do a single thing with that authentication error...Ive also tried deleting the cache to no avail also...frustrating man...frustrating..
Hi Machkahn,

Thank you very much for your help and support. I tried flushing DNS cache by following your steps. However, I still get the same error "Unable to download an authentication module". Please let us know if there is anything else we can try or any other information you need from us.
Is this happening for the live client or Heart of the Swarm?
I just got the beta key today so I downloaded and installed the app on my Mac (OS X ML). I get the same error after clearing the cache and the dns.
After all that I double checked WoL was still working. After launching it and logging in I got an "Error downloading content..." but the progress bar went through and the game worked fine.
I went back to Heart of the Swarm and it still can't detect my internet connection.

I found this post that might be the problem I'm having.
Yep. Same problem. Though there has been a patch on the 18th this problem clearly still exists? Just followed the instructions to clear my Blizz cache and still can't download the authentication module.

Join the Conversation

Return to Forum