Custom Games Bug

Bug Report
When I click on the arcade For SC2 Patch, Some of the Games I usually play such as Squadron TD the name is not there but instead there is a "..." When i Click on it, it doesn't load and if i try to get in with a friend of mine who can play it i get stuck on the "Entering Lobby" Screen. I don't know if it's a regional problem, I'm an Australian and my Australian friends cant join it but my american friends can. Anyone know how to fix it?
I have the same problem. my friends in australia can not join the custom games with us americans. They just bought the game because i told them how much fun it is and now they want to return it because for a few days they have not been able to join the lobbys we do as a group. I dont blame them, i would be furrious. if i pay for a new car i expect it to run. please fix this i know 8 people with this problem so it is not going to be a local matter it has to be wide spread.
I'm having the same exact problem. I am able to see and join some arcade games, but others are missing the picture and text (the ones I play like 1v1 obs). When I try to click into it, it goes to a blank screen and starts to load forever. This also happens when I try to go into the bookmark page.

I am currently playing on a PC from China on the US server. I have never had this problem before until recently.

Can anyone help? This is quite frustrating.
Use Google's DNS ( and Seriously though, any amount of searching gives you at least 5 other threads with the answer to this.
I am having the same problem with Arcade games, they only show the ellipses "..." and they never load? This is only with some games about half, I usually only play Aeon of Storms though... Anyone know how to fix this issue yet?
Same problem here. When I ask my friends to invite me to the game instead of me actually joining it, it says there's an error or something. I also get those "..." along with pictures of the games that don't load at all.

Please fix this Blizz! :(
Plz fix this Blizz!!!!!
So anyone find a way to fix this yet?
I'm having this problem right now - also an Australian, has there been any update about this issue yet?
I have the same problem, i think it's problem, because I tried to reinstall the game but it still happen the same.
hi all,

the link attached below is a detailed list of steps to take to fix this dns problem. its easy as it tells u which button to press, practically teaching u how to turn on your computer. follow it step by step and DO NOT SKIP STEPS.

here you go:

im not only having this problem but also cant play 1vs1, it says game ready but doeste do anything. also i tried to reinstal tha game and nothing, i trued to run on another pc and the same happen

Join the Conversation

Return to Forum