Unable to download Authentication module

Technical Support
Has anyone managed to fix this issue for Windows 7 yet? If you had success, please let the rest of us know. Damn you, authentication modules.
TheSlavic, there seems to be DNS issues in your region. Have you tried an alternate DNS server?
Monday - Friday, 8 am - 5 pm PST
TheSlavic, there seems to be DNS issues in your region. Have you tried an [url="https://developers.google.com/speed/public-dns/docs/using"]alternate DNS server[/url]?
Monday - Friday, 8 am - 5 pm PST

Hey Velnrak, thanks for the response. I will try to change the DNS server, but just a quick note that I was able to connect to battle.net without any issues in the past (from Japan). The game is registered to the NA region. I have been living in Japan for the past 4 years. Here's hoping the DNS issues in my region get resolved.


I got same issue cannot connect, I bought the game in US but I lived in Japan never had this problem , 2 months ago I moved to Hong Kong and I got
Unable to download an authentication module

I uninstall the game and install the asian version didnt have any issues but only allow me to play with the started version , unless I bought again the SC2
I submitted my ticket to Blizzard but no response yet
I have the same problem for a few days now,
I was not able to solve this problem by looking for anything found on forum batle net a guy who had done the same and what do probrema he said and it worked for me sorry that I can not remember his name but the credit and all who try it going to work down here let the procedure sorry my english

One. Download Hotspot Shield (search in google)
2nd. Install and run it
3rd. Start SC2 (Wings of Liberty)
4th. If the issue was authentication module error it would automatically be resolved now.
5th. If you could not download maps before (ladder or custom games), you can download it now.
6th. After all this is done, quit SC2, uninstall hotspot shield and start SC2 Normally like before.

This thread is for Those Who are still waiting to play the game and dont know this fix. To All Those who know, good for you: D
Thanks for the suggestion, it was the authentication module causing players in Asia unable to see. I tried your method and it works. Thanks CRC, I hope the staff fix it ASAP.

Join the Conversation

Return to Forum