Mouse Scrolling Not Working

Mac Technical Support
I just purchased a new iMac and downloaded SC2 everything looks great except that when I joined a game my mouse was not scrolling the around the map when i placed in the the edge of the screen. I checked in the settings and mouse scrolling is enabled so Im not sure what to do. Using the arrow keys to scroll around the map is a huge pain in the !@#.

Btw I am using a Cyborg rat 7 wired USB mouse however I tried switching to the apple magic mouse just to see if that was the issue but same thing with that mouse. Not sure what to do here if anyone knows how to fix this issue I would be greatly appreciative.
Can you post your full specs so we know what we're working with?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
I'm having the same issue.
I also have the same issue. In response to the post above requesting information...

System Version: OS X 10.8.2 (12C2037)
Kernel Version: Darwin 12.2.1
Boot Volume: Macintosh HD
Boot Mode: Normal

Chipset Model: NVIDIA GeForce GTX 680MX
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 2048 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x11a3
Revision ID: 0x00a2
ROM Revision: 3707
Display Type: LCD
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort

Model Name: iMac
Model Identifier: iMac13,2
Processor Name: Intel Core i5
Processor Speed: 3.2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: IM131.010A.B04
SMC Version (system): 2.11f14

It's a little backwards...

I talked to a customer service representative about this for a little over two hours the other day. We went through various changes/fixes/some scripts to no avail/changing options in-game from WINDOWED to FULLSCREEN - to turning off scrolling and mouse acceleration in game. Eventually, we linked it to some driver support.

The custom mouse I use, same as the original poster, was not registering properly with drivers on the computer. So...

  • Go to the developers website of your mouse, and find software updates for your mouse.
  • Download/install the software update.
  • Restart your OS.
  • That should fix the issue described above. The mouse accelerators, either third party scripts or your own, did not change the issue. They only increased the mouse speed. If the mouse continues to get stuck after you install the software updates you may have a different issue with the drivers.

    I'm not 100% sure this will, in fact, fix the issue of the map moving once you touch the edges of the screen; however, this did fix mine. If the issue persists more information could help find another reason for this issue.
    I'm also having the same problem except that my mouse CAN scroll in every direction except down. It has always worked fine until this last major update.
    Happening to me as well, with a Cyborg RAT and 10.8.3.

    This kind of functionality shouldn't require a driver.. USB HID compliance ftw.

    Launch game with mouse connected. No mouse scrolling.
    Use trackpad, no scrolling.
    Unplug mouse.
    Use trackpad. SCROLLY GOODNESS!
    Plug in mouse. Scrolly goodness remains.

    Launch game with mouse connected. No mouse scrolling.
    Use trackpad, no scrolling.
    Unplug mouse.
    Use trackpad. SCROLLY GOODNESS!
    Plug in mouse. Scrolly goodness remains.

    Thank you so much. I tried everything, updating drivers, repairing disk permissions, switching default monitors, numerous restarts, OS updates... All I had to do was unplug and replug in my mouse after the game had started...

    Welp, back to the game,

    I know the issue is a little old but I cannot find a proper solution to this problem.

    I know the RAT7 Mouse had issues in linux as well. xorg required a specific config to remap buttons to address the issue. It seems to me that these are very similar issues. Unplugging and replugging also temporarily fixed it.

    I've updated the drivers yet still get the issue. Any ideas?
    try logging out and then change the settings and then log back in, you w
    ill have to change the settings again.
    I just started having the same issue about a week ago after the last battle net updates. Nothing changed with my system except the battle net update. The fixes suggested in this post sometimes work and other times don't. Very frustrating and hard to play this way.

    Join the Conversation

    Return to Forum