Starcraft 2 stuck at checking for updates

Technical Support
First off

Dont try contacting Support, they just delete your ticket and not even help

That sounds like the complete opposite of support.
changing IE settings worked for me as well. tyty
IE settings solution works perfect ... what is this sorcery
Thank YOU!!!!!!
!!!Damouth!!! No it can be me also have freeze!!!What is that probleme !!!
where is IE ???
in the suggested help link :

I have a mac, i then selected advanced troubleshooting. it says to delete the tools folder. Type "" into the search of the hard drive and then the folder should pop up and delete it. restart the starcraft2 installer and it will create a new folder when it is "checking for updates..." and it will continue on fixed.

when i reinstalled this game it had the error of stopping at the "checking for updates..." The extra "" folder is probably left over after the first uninstall.
The Internet Explorer thing worked for me!
I spent the last 2 hours fiddling around with settings trying to get my games to work and IE LAN options worked. Peace out ya'll~!
Thank you ZERO. That was great. It worked the first time too.
Yeah the IE thing worked. Also fixed my Steam! Thanks!
Answer: close everything, open internet explorer, close it, then open starcraft 2 and play :)
what about those who dont have IE? mac users?

I deleted that file and now it stuck on " updating blizzard agent"
Hi Everyone! I finally found out what the problem was after trying all of the above. If you have Google Chrome installed, just simply uninstall it. I played StarCraft 2 whole day. then got bored and started browsing. Since I reinstalled my windows I decided to install Google Chrome. I then read some build orders and wanted to try it. I closed Google Chrome and opened SC2... It was stuck on the Checking For Updates Box... I then struggled for a while with the above steps until I finally decided to take one step back at a time starting with uninstalling Google Chrome. I kept the "checking for updates box open". The moment Google Chrome was uninstalled, SC2 opened like a BOMB. Back to BNet for me :):):)

GL if that doesn't work guys. I can only assume it has something to do with the browser. I since then started using the normal internet explorer as my default browser...

Hope this helps guys
Get this a way to get it to update, All you have to do is go to the Starcraft 2 folder then find the Temp folder and delete it.
hey my IE isnt even opening to the home page... its says IE is not responding then automatically closes the browser, thought maybe i need to perform a windows update but that isn't even working...

Any suggestions??
Well the IE trick didn't work for me.

Since the tools update that happened yesterday I get stuck at the "Initializing..." stage of the launcher, the play button is still gray. I tried doing a system restore earlier but that just prompted the update to repeat followed by the problem again.

I went through the steps that were advised and one of them (disabling the start-up service "Spybot-S&D 2 Scanner Service") got me past the "Initializing..." stage, but my browsers don't work without it (though I could probably reconfigure that since I haven't always used Spybot) in addition to SC2 then getting stuck searching for servers or something, prior to actually opening the full-screen SC2 program.

And just now while typing this, the launcher finally got past the "Initializing..." step (even though spybot is enabled so that I could be online). It took about 10 minutes where it was stuck there. Coincidentally it seemed to happen the same time my background changed (I'm using the slideshow background thing for Windows 7).

EDIT- so now it seems to work for me, it just took a really long time at the initializing step with no way for me to know that there was actually any progress or whether it was stuck. Even after restarting my computer the wait time is back to normal, so I guess it was just a one time thing.
Zero's solution worked for me. I use Chrome for all my web-browsing, however switching settings in internet explorer resolved the issue!
1. Open Internet Explorer (IE)
2. Go to "Tools" (It's the small gear button in the upper right hand corner of Explorer)
3. Go to the "Connections" tab
4. Click "LAN Settings" (at the bottom of the page)
5. If the box labeled "Automatically Detect Settings" is checked then uncheck it
6. Close and restart the launcher
I tried every other solution out there and this is the only one that worked for me. Thanks again Zero!

Are you kidding me? I've been all over hell and back trying to find a solution for MONTHS. This finally fixed my issue.

What the ie? I guess it got angry because nobody uses it. Passive aggressive internet explorer: Disables SC2 client from reaching so you have to use it to fix the problem.
Ill just ho ahead and add this to the list of reasons why i hate internet explorer

Join the Conversation

Return to Forum