Patch 1.5.4 problem

Technical Support
The last patch I have showing is 1.5.3. When the launcher pops up it says the game is up to date...and then when I click play, the game loads all the way to the log in screen and then promptly shuts down the program.

I tried digging through other forums for an answer...but, couldn't find one.

Any suggestions?
Hey Zombiestreet, Windows may not be allowing StarCraft II to completely patch, and I would run StarCraft II in Administrator Mode.
Monday - Friday, 8 am - 5 pm PST
Tried it. Also, tried msconfig selective booting thing...and I uninstalled my anti-virus program (avast).

Nothing worked.
is your windows up to date? ie is sp1 installed, windows 7?
Everything is up to date.

I'm going to re-install the game in the next day or 2.

Thankfully, this problem is occurring on a secondary computer. My main computer is not experiencing this problem : )
I just tried reinstalling the game...and now I'm receiving a "communication error" when I click the install button.


Join the Conversation

Return to Forum