Cannot select race or match type

Technical Support
Hi guys,

SC starts up fine and dandy, everything runs smoothly, but for the past few days, whenever I try and load up a match, the window that would usually allow for your race select, and match type (1v1, 2v2, etc.) is completely empty. I have been searching around for this and can't find a resolution, so the forums are my last hope. Any help at all would be greatly appreciated!
I am having the exact same issue and have currently been dealing with a tech rep about it, but to no avail. I have tried everything from re-installing to deleting my anti-virus & disabling my firewall, but again, nothing seems to work. Any info would be a really big help with this.
Hi guys,

Let's try these steps and see if they help:

1) Reset your network
2) Flush the DNS cache
3) Try alternate DNS Servers
Monday - Friday, 8 am - 5 pm PST
Thanks Velnrak, it worked! I reset the network, then flushed my DNS, then reinstalled, then repeated the process, and afterwards everything started working!
I am having this same problem... I cant figure it out. I Flushed the DNS cache and everything. Why cant this be more simple lol
Exact same problem. Multiple threads in this section stating the exact same thing, meaning it's not our end. All I want to do is ladder ffs
it doesnt work!!!!!!!!!!!!!
Chiming in, same problem
Tried steps 1 and 2 and still blank quick match screen. Does this have something to do with the latest patch. I could try reinstalling...
Could I assume that all of us have SEA licenses as well?
Already tried re installing. Didn't work. I can confirm, I have a SEA license and live in Australia.
same problem here. Live in Australia but have US client and play on US server. Would really like a resolution soon...
Hi guys,

Let's try these steps and see if they help:

1) [url=""]Reset your network[/url]
2) [url=""]Flush the DNS cache[/url]
3) Try [url=""]alternate DNS Servers[/url]
Monday - Friday, 8 am - 5 pm PST

t didnt work!!!!!!!!!!!!!! I cant play with stupid rob all day long!!!!!! plz!!!! any other solution??
This is pretty shocking, it's clearly a widespread problem (at least for anyone with an SEA license playing on the NA servers) and yet after several weeks nothing has been done to fix it??
I am having this issue as well. Tried the fix and nothing. I can't even join games when invited by a party. I am stationed in Germany so it could be the same issue other folks are having.
Yep, same problem for me. I'm from N.Z. Tried all the suggestions, still can't play.
Same issue for me here too. Tried the above fixes and didnt work.

EDIT: This is only when i try play on NA servers...Which is the only server worth playing for me...
I've also tried that and it still doesn't work. But it's not just quick match for me. It's all co op and arcade that wouldn't work -_-
same for me Louie

Join the Conversation

Return to Forum