Unable to download authentication moduleHelp!

Technical Support
Prev 1 2 3 7 Next
I live in Japan, too (if that even matters). Been having the same problems for about 3 weeks. Started when I reinstalled Starcraft 2 after upgrading to Windows 8. I've reinstalled Starcraft about 4 times and have followed every piece of advice I could find on the net.
Tried changing DNS to
Didn't work.
This is what I got with nslookup us.depot.battle.net
Server: cdns01.kddi.ne.jp
Address: 2001:268:fd07:4::1

Non-authoritative answer:
Name: gs1.wpc.edgecastocdn.net
Aliases: us.depot.battle.net

The TelnetClient commands don't seet to work with Windows 8
I changed it since 1 week ago and it worked. But after patch 1.5.4, it wont work anymore, what about you?
Ok...So changing your DNS is a quick fix to this problem.
I changed to Googles DNS
it's actually quite simple to do aswell.

It has worked for the past week!!!
I had to do this as well with the recent patch. Not quite enjoying it since I have noticed some websites for some reason (IE: Chase) lags and takes forever to load now since I did it. Would love to see this issue resolved.

Have a friend that lives in Singapore state he had issues at first after initially patching and he reloaded SC and it went back to normal for him. Obviously not the case for everyone but doesn't seem to be a location based issue.

Live in AZ, US.
Currently in germany and just got a win8 laptop.
After install and patches, i an also receiving the Unable to Auth. error before even clicking connect.
Also receiving a similar error in D3.
Also having the same issue as above

Have taken all of the steps mentioned by the 'Support Forum Agent' before he disappeared including

- changing DNS settings
- ipconfig release, renew, and flush DNS
- running the repair tool
- clearing the cache C:\ProgramData\ ... etc
- allowed SC2 in the windows firewall (already was)
- uninstalling/reinstalling SC2

Going through the multiple threads on here it seems I am not alone, yet there is a disturbing lack of follow-up by the forums reps here
This is crap, I have it as well

Even after re Installing. Im running on Cable Internet

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Owner>nslookup us.depot.battle.net
Server: dns-cust.fli.bigpond.net.au

Non-authoritative answer:
Name: gs1.wpc.edgecastcdn.net
Aliases: us.depot.battle.net, wpc.758c.att-acdn.net

C:\Documents and Settings\Owner>
AUS. Brisbane cannot log in either.
Cannot even play it offline... What a rip!

How many page's till we get help????? For real.. You stopped me from playing offline. I cannot get in. This is why I didn't buy D3.
I'm in Australia like you last two

Any update please Blizzard?
I've tried everything mention here and everything on other sites. I initially had problems with Minecraft too, but have a reinstall, that and every other game works fine. I think something's wrong with Blizzard's security protocols.
I am also from AUS with issues, you AUS blokes arnt with Cable Bigpond by anychance
same problem here. i'm from Israel and i play on american server, when i try to play offline it tells me i need at least one starcraft 2 character in the account...
exact same issue here, from JAPAN!
01/19/2013 04:28 AMPosted by eXzium
you AUS blokes arnt with Cable Bigpond by anychance

i am
Ok, just realised, I had a US version of the download, so I downloaded the SEA version and I can now play. However the games I play arnt on the SEA region, I cant seem to move to Americas region in the loading screen, I go to login then it loads then doesnt do anything else. Then I have to quit
I can finally log in. but now i can't start a game. when i click on the quick match i page is empty, no 1v1, 2v2... and no races to choose from.
Also my achievement points are at 0000
Mine is the same DeWise, However all my arcade games are greyed out with out getting any names coming up.

Im trying the Repair tool as I type
I don't think using the repair tool would fix it. i think it's some kind of connection problem.
Update on this issue please. 9 hours ago I posted. I AM STILL UNABLE TO PLAY ONLINE OR OFFLINE.
Update on this issue would be great.

Join the Conversation

Return to Forum