Failed to download required file...

Mac Technical Support
I have done it all but the lock keeps locking back up
I'm having the same problem. It's stuck at 50% and has been each time I've restarted SC2 since last night.
Have you tried deleting the Battle.net Tools folder?

This may help.
I'm also having this problem. I deleted the blizzard tools folder as instructed. The game is stuck at 2.2% downloaded when I get this error message.

Specs:

13" MBP Early 2011
Processor 2.3 GHz Intel Core i5
Memory 16 GB 1333 MHz DDR3
Graphics Intel HD Graphics 3000 512 MB
Software OS X 10.8.2 (12C60)

What else do I need to do?

Go Zags!
I have the same problem. I did everything Machkhan said, but still having the same error.
Need help, please.
i am trying all of the things listed here because i have the same problem as listed above. i get stuck at 0.1% This is very frustrating.
Even though I had the permissions correct visually, I had to go through this and hit the lock, enter passwd, then hit the gear without changing anything and it worked.
This worked! swaggin!
I also have this problem. Tried the unlocking solution to no avail, also tried to delete the battle.net tools folder, but no such folder is present in my Starcraft folder on my Mac. Please help, thanks!
Hey i have the same problem and i tried the step by step directions above and still nothing. I tried everything i can find. Think you can help me out?
I'm having the same issues, but it's because i had to re-install starcraft cause the one before was broken. I downloaded it from battle.net, and that happens even before it begins to optimize
Anyone can help me?
This is my exact issue as well.

Between the last time it worked about 1 week ago and today I updated the following 3 add-ins to the latest version on my MAC.

Adobe Flash Player
JRE 7u25
and Shockwave

Are any of these three what might be causing the issue?
i am also experiencing this problem. tried adjusting the permissions and deleting the battle.net tools folder and neither one helped
Hi,

In order to fix this issue on Windows, please:
  • Go to %APPDATA%/../Local/
  • Select "Battle.net" folder
  • Right-click "Battle.net" folder
  • UnCheck the "Read only" function (make sure it is UNCHECKED).
  • Apply to all subfolders.
  • Apply above steps to your game folder installation.
  • Everything should be fine from now on.

    Have fun in game!!

    Join the Conversation

    Return to Forum