Certain Computer Configurations Slow to Start

Bug Report
Since i cant figure out how to edit my post...i have an i7 3770K cpu with 2 cores disabled so i can get better single threaded performance with lower heat and voltage...(i was getting 104C with 4.5ghz clock 1.33 volts instantly with small fft on prime 95 and thats with liquid cooling...said my processor was taking 110 watts the top tdp is 77 watts WITH igpu so with it disabled is about 60-65 watts also is a 22nm chip so hurts it even more) also have a z77 extreme4 motherboard 240gb intel 520 series ssd 500 watt power supply 7850 HD graphics card 24x dvd 8gb ddr3 memory and dont say that my cooling system is messed up...its over 12C cooler than stock fan...but ya 4.3ghz no freezes 4.4ghz and above freezes/crashes and generates memory errors when it crashes cant tell if its cache mem errors or ram errors...pretty sure cache ram errors (as i said probably due to low voltage)

edit: wow now it lets me edit this post but not the other one thats messed up

theres a glitch it STILL wont let me edit my other post...

o and 105C is its tjmax...if i had throttling off would of easily hit 120C within 30 seconds if not even higher...

like 4th edit...forgot to say i ment i was getting 104C with 1.33ghz ALL cores enabled 45x multiplier small fft on prime 95...if i do like 100% cpu usage with blend on prime 95 it takes alot longer to get to 104C...and says its only taking 102 watts vs 110 watts...small fft takes alot more heat on cpu) got it up to 42% throttle after running for about 10 seconds small fft about 70 degrees in the room...good cooling in the case...liquid in pump not too hot...ok sorry anyways got off topic...yes the game is very unstable at a high overclock

need to fix the cant edit post glitch
Yeah have to admit, same issue here guys. I have a SEA account and I get 5 seconds stutter in game before a game on SEA and 15 seconds to NA - even if it is a replay therefore it cannot be a connection issue. I have no idea what it is, the mouse cursor goes green as though the game is ready to play and when it starts I'm already in the lag screen with 0:12-0:15 on the clock....

I play from Australia running everything on low, no issue before 1.5 patch...
probably because your in Australia...what is your latency?
It's about time. But now the real question: does this actually fix the issue? My thread has finally been closed: http://us.battle.net/sc2/en/forum/topic/6233033873?page=12

Geez. I haven't played Starcraft 2 in months, ever since 1.5 ruined the game. The only connection I've had (for the most part) with the SC2 community was that thread. I hope this is finally a proper fix.
Why not get all the players into the game. Then do the Start - That way its insured all the players are present and ready before they can start..

Or they can select an "I'm ready box" to start the count..

Yes, this. Honestly this sounds like both a simple and elegant solution. What sense is there in the current countdown *before* the game loads? 3 second countdown, indeterminate 2-20 second delay, sudden start. Put the countdown *after* everyone has finished loading, and suddenly it's fair. Not to mention, no automated start to mining is required...
My system seems to be better for the 4 games I've played so far tonight. Before I'd lag about 5-7 seconds then another 2-3 of slowness before it started now it's immediate and smooth. I recently upgraded video cards from 2 GTX280's to 2 GTX680's but the problem persisted.

my setup:
ASUS P9X79 Pro with an i7 (3820), 32GB RAM, 128GB SSD (System), 2TB HDD (game/storage), 2x GTX680 (sli)

I do run with everything enabled (gfx-wise) @ 2560x1600
There is still a delay.
Unfortunately the delay is still there for me. I made a video of the issue to see if others are having the same problem, or perhaps a slightly different problem.


For those who the problem has been resolved, was this what you saw before?

I recorded this at 15 frames per second. On faster, each game second should be 15/1.4 =~10.7 frames. In the first frame, the clock reads "0:00" and the surrender screen is up. In the second frame, the surrender screen is gone, and the clock still reads "0:00". In subsequent frames, the clock reads "0:01", "0:04", "0:06", and then "0:07" for 4 frames, and "0:08" for 9 frames. After this, the game clock is moving at the right pace.

I have reinstalled both the game, and the OS with no luck. I also tried running on a fresh OS install with only the network and video drivers installed.

I think this has been mentioned before, but I find it highly interesting that the problem is completely nonexistent in Single Player "versus a.i." The clock starts right at "0:00" and stays there for a full game second every time.

Computer config:
Windows XP
Radeon HD 4870 1GB
Asus M3A79-T Deluxe Motherboard
Integrated Ethernet
AMD Phenom II X6 1100T (3.3GHz)
240GB Intel 520 SSD
Since coming back after leaving for months due to 1.5's incredible, INTOLERABLE starting lag in quick matches, I now find that the same bug still exists plus it now has a cousin named "randomly disconnects mid-game."
Guess who still has the same 15 second late start issue??? This guy. At this point, with that late of a start it feels like a gift whenever I win a game considering the headstart my opponent has that I have to overcome. So far it doesn't look like this supposed "fix" of a patch actually fixed it for many people. Your move Blizzard.
My game still loads 7-8 seconds late every game after the newest patch, I run Windows XP via bootcamp on my 2007 iMac. Possibly worth noting is that when I first had this problem it was just 3 seconds long, later on it became 5 seconds, and eventually it became 7-8 seconds. After this newest patch the beginning of the game seemed to start differently, like it started on time but then fast forwarded 7 seconds instantly.

On the bright side, the occasional 5-10 second game freezes I got before seem to have disappeared.

System Specifications:
Mainboard : Apple Inc. Mac-F4238CC8
Chipset : Intel GM965
Processor : Intel Core 2 Duo Mobile T7700 @ 2400 MHz
Physical Memory : 2048 MB (1 x 2048 DDR2-SDRAM )
Video Card : ATI Mobility Radeon HD 2600 XT
Hard Disk : Western Digital WD5000AAKS-40TMA0 (500GB)
DVD-Rom Drive : MAT!@#$A DVD-R UJ-85J
Monitor Type : M201EW02 VB Color LCD - 20 inches
Network Card : Broadcom BCM43XNM 802.11n Network Adapter
Network Card : Marvell Semiconductor (Was: Galileo Technology Yukon 88E8058 PCIe Gigabit Ethernet Controller
Operating System : Microsoft Windows XP Home Edition 5.01.2600 Service Pack 3 (32-bit)
DirectX : Version 9.0c (May 2010)
Mine seems to be working just fine at load.

Macbook Pro Mid 2012

Processor: 2.9 GHz Intel Core i7
Memory: 8 GB 1600 MHz DDR3
Graphics: Intel HD Graphics 4000 512 MB
(NVIDIA GeForce GT 650M with 512MB of GDDR5 memory)
Software: OS X 10.8.2

Running on US server
I have the same issue as Moobla.

I definitely used to experience the load issue. It never seemed to be more then about 5-7 seconds. Now It boots me into the game, but my units will not respond for the first ~2-3 seconds. I know the commands are going through, the game will do this sort of fast forward skip to after ~2-3 seconds. I can send commands, but it is just a little trickier without any visual feedback.

2.4 GHz Intel Core 2 Duo
4 GB 1067 MHz DDR3
NVIDIA GeForce 9400M 256 MB
OS X 10.8.2
As a game developer with online components, I know the rage from users is going straight to the forums when something is going wrong. Once this is fixed, they never come back.

So I will break the spell, and let you know, the waiting time has been constantly down to 2 seconds for all my recent matches. We are almost there, good job !
as a user who bought this game when it was released, and was patient as hell while zerg
was ludicrously UP (check the patch logs, they got buffed about 10 times with the other races
getting nerfed like ten times.... CLEARLY we were right back then... but nothing but BS
from anyone else on these forums.)

I've been again waiting patiently for the bug introduced in 1.5 to get fixed and it has
not been.... The only reason I post in these forums is to communicate with staff
if at all possible. I respect almost none of the forum users. I do not expect anything
helpful or relevant from them. I do not even read the replies I get... why?

I post to tell blizz when things go wrong, because the rest of you are not even remotely
interesting to me, and never will be. this is the internet remember? troll city.

obviously do not bother replying.

I do like this game. And hots actually looks like a great expac... I had my doubts a few
months ago.
Umm not to burst any bubbles but whatever it was that u guys think you fixed, you didnt i now not only start with a later delay after that patch BUT every time on top of getting the 18 second start delay i get about a 10 second lag dropout in the very start of every single one of my games, 1v1 2v2 3v3 and 4v4 all have over a 15+ starting delay...... WTB fix or imma cancel my preorder...... why play if u cant even be even.....
It's good to be fixing this obvious problem, but could we get a simple 3... 2... 1... count down timer once both players have loaded.

I'm tired of having to watch a jumping sporadic progress bar to know when the actual game will start. It seems trivial to add a count down timer and I can't think of a single valid reason *not* to include one.

Seriously why not include one? Is there some deep important reason why having to watch that progress bar randomly move across is better game design? I feel like there has to be some reason it hasn't been fixed yet, or else it would've been done already.

Did really no one ever think "hey, what if instead of relying on random computer loading, we had a standard count down so everyone was clear when the game would actually start?"

I'm honestly curious to find out why this hasn't been done yet; the amount of coding to do it has to be relatively small. I will be very impressed to see a valid reason not to have a small count down... and crazy mental gymnastics doesn't apply.
I hope noone takes this the wrong way but they're not going to put a timer in. I gotta assume this issue only affects a small percentage of hardware configurations and adding a timer would be a change that would affect massively more people. Its good you guys are here giving feedback because everyone should have a good gaming experience but it shouldnt be fixed at the expense of the overwhelming majority.

For what its worth my PC is a frankenstein I made from parts ordered on newegg (first attempt) around a year ago and have never had problems with WOL or HOTS start delay. its an AMD Phenom X4 955 with a Radeon 6800 graphics card. budget PC but runs SC on ultra like a champ.
I think HoboKing is right, the hardware is the main problem here.... we unfortunately have to stick with recommended configration or proven configurations that works with specific graphic gards and CPU.... So for mac people (like me) or others, we will have to change.
Fortunately in the ladder, 2/3 of the people have the same problem so we begin all delayed which is quite good in order to avoid Imba.

I think the 2 easiest solution should be :
1 - To put a countdown at the beginning (i don't think Blizzard will do this)
2 - To put a message with 'Press any key to begin'. I think this solution will be very easy to implement knowing that in some custom arcade maps, this feature is included.
Thus, the two players will have to wait each other to press a key to begin a match.

Hope blizzard will fix this soon, but frankly with the release of HOTS, they are busy 'polishing' and refining the balance and the game to have a decent release..... so i don't think they will worry much about this...

But i want to know if the same problem is here with the beta of HOTS, someone ?
HotS fixes the issue for me. The latest WoL patch does not. I still load 7-10 in game seconds late into the game.

Win XP
Radeon GPU

seems to be a reoccurring issue with xp and radeons.

Join the Conversation

Return to Forum