Certain Computer Configurations Slow to Start

Bug Report
I think this has been mentioned before, but I find it highly interesting that the problem is completely nonexistent in Single Player "versus a.i." The clock starts right at "0:00" and stays there for a full game second every time.
This is because in vs A.I., you are playing offline. When playing vs A.I., you may notice that your clicks are registered instantly, as opposed to the short delay experienced when playing online.
HotS fixes the issue for me. The latest WoL patch does not. I still load 7-10 in game seconds late into the game.

Win XP
Radeon GPU

seems to be a reoccurring issue with xp and radeons.

yup, lotta radeons specifically I noticed a lot of radeon HD4xxx cards on win xp
posted about.

good to know they spoke the truth when they said hots recived several extra
tweaks than wol did initially, makes me believe they will fix my problem with the
next patch... as they have it fixed on hots already... My anger is really really
low about this actually... clearly blizz is busy with important worthy stuff right now.
Hots looks pretty great imho :D
Personally I always felt the game would not have the issue of different load times, and a more epic and appealing beginning if at the beginning it just said "Ready, 5, 4, 3, 2, 1, Begin!" or something along those lines. This would ensure everyone would be ready to play, and it would start at the same time :D
HEY! I went and played on EU and guess what?!?!?!!?!?!?

my lag dropped to 4 seconds in game, it is 9 on NA,... lol dunno.

if someone was upset about start lag they could head on over :P
Oh please help, its imposible to play with that problem i start every game like 20 seconds later, i begin my first SCV production in second 20, or 21 when my oponent starts to build the second one. This problem didnt existe before, its like a 6 - 8 week ago i start to experience it, the last patch didnt solve the problem for me.

Processor: Intel Core i7-930 2.8ghz
Board: Asus rampage extreme III
ram: 6144 mb triple-channel DD3 corsair
video: Nvidia Gforce GTX 470 (Asus 1250mb)
OS: Windows 7 Professional

Please let me know anything you need. Thanks in advance
how can i get the package language?
The Map Editor seems to not be able to publish, it seems the map editor is not in tact with the original games it self, (different versions)
Still experiencing the same issue in WoL. What is the problem with a simple 3-2-1 countdown after both players have loaded?
Upgraded from a 2.8ghz dual core with an NVID gpu which worked FINE to an i7-3990, radeon 1gb ddr5 gpu, 8gb ddr5 and now I cannot play the arcade and start into games 15s late. Can we get some of the players effected by this to offer dxdiag/etc outputs to help identify the issue?
02/01/2013 12:48 AMPosted by Yaksha
Still experiencing the same issue in WoL. What is the problem with a simple 3-2-1 countdown after both players have loaded?

the goal is that there is no countdown, but that both start at the same time,
now... if they simply added a countdown one guy would start the game at
5,4,3,2,1 right on 1 and the other guy counts down to 1 then sits there for 9
seconds after 1...... still 9 seconds behind the first guy... why? fundemental
code problems.... once those fundemental problems are taken care of
we will start at the same time with or without a counter.

the important thing to know now, is that the load timing is off, so any sort
of attached game start timer would be affected anyway and inaccurate.

they need to line up the clients loading properly. Which is apparently
so hard because different machines have different advantages... for example
some of us have sick fast ram / HD and our load times have that advantage
while other people have multi cores.

theres all sorts of ways timings get knocked off, between cpu prowess, driver architecture
motherboard layout (pipelines / bottlenecks) page file use, what windows version you have, etc etc etc.

02/01/2013 07:23 PMPosted by AntBoot
Upgraded from a 2.8ghz dual core with an NVID gpu which worked FINE to an i7-3990, radeon 1gb ddr5 gpu, 8gb ddr5 and now I cannot play the arcade and start into games 15s late. Can we get some of the players effected by this to offer dxdiag/etc outputs to help identify the issue?

I've read a bunch about radeons being affected.... quite a few HD 4xxx series
your 3990 is probably involved.
After patching and wanting to log in to Starcraft 2 I cannot connect to my battle.net account. On trying to connect not only am I unable to connect, but my whole internet connection drops until I close down Starcraft 2.

I have enabled port forwarding for all the required ports, updated my router firmware and network drivers but to no avail.

I've seen that others have had this problem too but I don't seem to have found a fix.

Any help would be greatly appreciated!

(This started when global play patch came out on WoL and when multiplayer replay thing came out on HoTS ; at first it was just severe lag in game, but now I'm lucky if I'm able to log in successfully.)
Sometimes I get global internal error or I can not connect to battle.net servers because my internet is not working even though my internet is working fine.
I also have trouble connecting to their battle.net website, so I'm unsure on what to do. I've made sure that none of my computer parts are the problem and I did everything their forms said to do. Need help, I'm clueless.
HEY EVERYONE i FOUND A FIX THAT ACTUALLY WORKED FOR ME!!! On the other bug forum some guy said he fixed it by uninstalling "Asus osd", I never even knew I had this and I don't use it so I figured what the hay? And boom instantly went from starting each game at 15 seconds in to starting at 0-1 seconds in, worked like a charm, anyone with Asus osd on their computers should try this fix, so HAPPY RIGHT NOW :DDDD
I know how hard getting rid of bugs can be, I do it for a living. My bet from the outside is that there is some difficult issue in multi-threaded code (just a guess).

I have some information that should be helpful. My computer stats are posed on a prior comment on this thread.

I looked at the number of bytes being send and received on my network card while the problem was active. In this test, the games started late by 4 seconds, real time. I used a stopwatch to be really careful with the timing, and back-calculated the time the game should have started. For example, the game clock should read 14 seconds after 10 seconds of real time (1.4 for faster * 10) "Second 0" corresponds to when the game should have started, up to 1.4 seconds of game clock time. Here is what I found:

Second -1: TX 128 RX 74
Second 0: TX 164 RX 375
Second 1: TX 0 RX 744
Second 2: TX 0 RX 916
Second 3: TX 0 RX 728
Second 4: TX 2678 RX 2236 <- Game appears on my screen here.
Second 5: TX 424 RX 612
Second 6: TX 448 RX 584
Second 7: TX 468 RX 604

Communication is fine, initially, but then the transmit side stops completely. Only after a flurry of traffic on second 4 does the game show up on my screen.

I tried a further test. I repeated this experiment while also transmitting a file across my local network. The results for Starcraft were similar, however the file transmit continued uninterrupted during the game start lag, indicating that my OS is capable of transmitting data during this time.

Yes, it's only 4 or 5 seconds, and I've been working my way through the Silver league with the handicap. It's annoying, but it hasn't stopped me from playing. Maybe I'd be Gold now without it (probably not though...) I know people are reporting 15 to 20 second delays with decent hardware, and that would really take the fun out of the game.

I'm sure there's a lot of smart people playing this game. Would it be possible for Blizzard to communicate a bit more with us on this issue? I know your team is reading these, but a little back and forth would help take some of the frustration out of the issue and help us get to a solution faster.

I have my fingers crossed for the 2.0 Patch.
Hey for the patch on Feb 20, 2013 why am i stuck reconfiguring 50%? anyone have a clue?
It works!

I just got the new patch, and I am starting the game consistently at 0:00 every time. I also noticed that the game appears to have a smoother flow to it. I hope it worked for everyone else too.

It's great to be able to focus on the game, and not the bug. I just ordered HotS. Thank You!
I started this thread to discuss the lag introduced in patch 1.5: http://us.battle.net/sc2/en/forum/topic/6233033873?page=1

It has, unfortunately, been locked with Blizzard claiming to have solved the issue, so I decided to start playing a few games again. I regret to report that the issue described in my original thread still persists in a more minor fashion. As I wrote in my thread:

It often lags for 1 to 3 seconds every 20 to 30 seconds or so, and then produces an enormous amount of lag in medium to large battles, making the game impossible to play.

It is highly frustrating and beyond annoying to deal with. I almost have to stop playing again until the issue is solved, and I just started playing for the first time since 1.5 was introduced in Summer. No way I'm buying HOTS at this rate.

Luckily I, among other members of the community, are almost sure of the cause of the issue. It is obvious it is not a problem with users' computers, as the game ran fine prior to 1.5. It is an issue with a "feature" introduced in 1.5, and that is additional streamed data.

A simple check box in the options menu to disable streamed data introduced in patch 1.5 would solve this issue for many users. I really hope Blizzard considers it.
It's just as bad as it ever was.

The only difference now is that there is a cute little scapegoat with the background patch download issue introduced in 2.04, which has nothing to do with this issue, but I'm sure will be mistaken for it.
I am still getting a ~4 second late start, and intermittent stuttering. For seven months. I've described these multiple times in detail, and you know what I'm talking about anyway, so I won't bother again.

I can't believe you guys screwed this up so bad. Next time why don't you charge per month and do it right.
I havnt played in months because of this issue. I purchased HOTS last night and went home to patch WOL. I was so far behind on patches i didnt get a chance to try it last night but if WOL is not fixed i dont think im even going to attempt HOTS.
I am now at Heart of Swam,

It is very slow to open "Menu" in game and slow again to open any sub menu.
Saving is slow too.. It is usually a 5-10 secs delay for each step Is this normal behavior?.. I believe that these menu items instantly open in Wing of Liberty

(I am in campaign mode)

Join the Conversation

Return to Forum