Loop: StarCraft II requires a patch. Would yo

Technical Support
Before I start, I have starcraft 2 on disk, and have played in on a different computer. I just built my computer, and the drivers are up to date.

So heres where I'm at. I have Installed starcraft 2 from the disk. Afterwords It says it's going to download 1 of 24 patches. However the update screen keeps shutting down with no error message.

First attempt to fix: I manually downloaded the 1.4.4 patch from the battle.net patch page, and it started looping from the It kept patching this same file over and over for about 2 hours.

Second attempt to fix: I downloaded the 1.4.3 patch from a secondary website, it got my starcraft 2 updated to this point. However when I tried to have the standard starcraft2.exe file do the rest, it continued to shut down.

Third attempt to fix: I continuously opened the closing file and have it go 1-2% up each time. And then, when it finally go to 99%, whenever I reopened it it wouldn't go any further.

I'm on windows 7 64xbit
My pc is good enough to run this.
Safe mode didn't work
I'm on administrative account and also tried run as administrator.
Also, when it first loads up, it says patching to 1.4.4. Wondering if this should be 1.5.
I've tried doing all this with the client downloaded from battle.net.
I don't receive a single error message when the update screen shuts down.
All of my firewalls are off.
Do not tell me to uninstall and reinstall, as I've done this too many times already.

Any input would be nice, as my support ticket has not been answered. Thanks for you time.
01/17/2013 05:27 PMPosted by ninjaboy
I'm on administrative account and also tried run as administrator.

Hey ninjaboy, I'd create another administrator User Account in Windows, and try installing on that User Account.
Monday - Friday, 8 am - 5 pm PST

Join the Conversation

Return to Forum