[Mac] Cannot play NA only SEA (+Screenshots)

Mac Technical Support
Picture 1:


When I try to ladder, nothing shows up.

Picture 2:


When I make/join a custom game.
I also have a mac and I am having the same problem.

It seems to me just incredible that a company like Blizzard would face so many issues with Mac both in WoL and the HotS beta. I haven't been able to play HotS for a few weeks and now Wol.

I hope Blizzard realizes soon it is a big mistake to keep ignoring Mac users. If they had any long term vision they would be paying more attention to Apple.

I'm very disappointed.
Try removing the Battle.net Cache folder and try again.

@Watcho- The HotS beta issue for Mac is something that is being worked on to resolve. The teams aren't ignoring Mac users, but want to make sure the issue is completely resolved along with other issues in beta. Being beta, things are still under testing.

As for the WoL issue, try what I suggested and see if it works. If it doesn't, then let me know and we can investigate further.
@Machkhan - Thanks for the quick response, I do appreciate the feedback.

Regarding the WoL issue I am having, I have tried what you suggested but it doesn't seem to work. I restarted my computer and the game after deleting the folder and I see no change. I would be very grateful for any other suggestions. @Ryo - did this work for you?

Regarding the HotS beta, yes, I get it. I do know that Blizzard is looking at it and I do know eventually it will get fixed. I think I am just frustrated as many other Mac users that the expectations on this were managed so poorly. I do follow the forums and I see there have been a few updates here and there, but saying something like "this may take a few weeks, please be patient" suggesting a time frame would help.

As an outsider to Blizzard though a big player and fan, my feelings have not changed and I am quite disappointed. I just hope HotS is amazing and makes up for the hiccups for Mac. And I also hope that Blizzard takes Mac more seriously in the future.
I cannot download the authentication module now.
I have the same issue but I'm not on a mac, at first the ladder buttons showed up but when I clicked 'Find game' it would say can't download map. Then I deleted the cache and now the ladder buttons dont show up at all.
You're probably affected by the AUS/NZ/South East Asian DNS issue. Try using the workaround in our sticky to see if it helps.

Join the Conversation

Return to Forum