Full Edition has now become Starter Edition?

Technical Support
1 2 3 6 Next
Having a problem. I was playing the Wings of Liberty Campaign last night when the game crashed. I thought nothing of it and went to bed. But now that I'm up, I went to check my game, and I found that when I logged in, Starcraft 2 thinks that I have a Starter Edition of the game and asks me if I want to update to the Full Version.

After playing the full version for 2 years now (since the game was released), I'm a little surprised to see this. So I went searching online for a solution, and there's doesn't seem to be a topic on this, so I figured I'd make a thread and ask for help. When I go into my B.net account management, the servers show that I now have a Starter Edition of the game with 2 public test realms underneath it (I don't really know what that means, and I don't see anything one the Starcraft 2 battle.net site saying that there's some maintenance going on or something).

If I could get an answer to this, it would be really helpful. Thanks.
Same problem here.
Seem problem is on SEA server only? I can play as Standard edition in USA server.
I am also experiencing this issue.
I am as well. The only reason I can see why is because I disconnected my internet momentarily (for various reasons). I started the .exe file to take me to the main menu of Starcraft II. I then realized only then that I had forgotten to turn on my internet again. I did so (while SCII was still running) and now it gives me the "Upgrade Now!" option, even though I already tried various things to fix it. I tried the following;
1.) Setting my clock back, etc.
2.) Repairing my connection.
3.) Reactivating my key code (to no avail.)
4.) Restarting AND shutting off my computer.
5.) Reinstalling Starcraft II.

I've tried all these several times and it still thinks I have a Starter Edition. Frustrating, but I can see why it may be my fault. Still, I'm hoping someone can find a solution.
Well, my Battle.net account information shows that I have a Standard Edition again, instead of starter, and I can now download a digital client copy, by when I run Starcraft 2 and enter my infiormation, it still pops up with the Starter Edition business. o_O.

Not sure where I'm supposed to go for changing regions, but as far as I know, Battle.net shows that my account is set up for NA. I'm thinking that a technical support call is in order, after I've uninstalled, reinstalled, and re-downloaded all patches for the better part of this morning.
Okay, so I followed the link that Dagger has been putting up on other forums about the SEA regions having trouble. Changed my email address in Battle.net to a new email address that I had to create. NOW I'm able to log into my Standard Edition.

Hope you guys try this out and see if it works for you. Good luck.
Can you show me the link? I am having the same problem but my region is USA and bought the digital copy. Played the full version yesterday :(
Also getting the same problem, shows in another post as solved, but my clock is correct. has not changed, and I haven't played starcraft in the past two days so I don't think it was anything I've done, ran a repair and everything and still asking for starter edition...Any ideas guys?
same exact issue here.....

This guy changed his password and the issues was solved. I changed my password and the issues is solved.

SOLUTION: Change your password.
Sorry for not posting back, guys. Here's the link that Dagger's been posting up. Seems this issue has been known and is just hitting us here on the other regions.

Mine did this too. As I don't have an active internet connection right now, im bummed. I have tried re-setting my password, no luck. Somebody please help me.
I recently purchased the game and it stated i have both Wol Standard edition and Hots Standard edition.Upon login i am stuck with standard edition...i did their stupid troubleshoots but to no avail it does not work for me,sent tickets and contacted support...they send me the same methods to fix the game but they are useless upon my game.They need to fix this issue ASAP because i am not able to play with friends after buying their game :c

However my brother when i purchased the game for him,he has no problems at all! He can play the game fine and launched it flawlessly with no errors!
I have changed my email address and my password but my client is still stuck at starter edition.

I just bought the digital, standard copy of WOL yesterday.

I have sent a ticket to Blizzard. In my account summary the WOL is registered as Standard full copy, global and unlimited.
I've got the same problem.

This is the answer from my ticket.
"Due to security concerns, there is a processing time involved in the approval of accounts upgraded through our website. If you have recently upgraded an account and find that you still do not have full access in game, this is due to the fact that the account is currently pending approval for the online upgrade.

Immediately upon upgrading the account, the leveling restriction on the account has been lifted and you may begin leveling freely during this processing phase. However, communication options will still be limited until the upgrade is complete. This means that you will still not be able to speak in public chats and you will still be unable to trade, sell, buy, or send things to and from other players. This processing phase may take up to 72 hours to complete.

If it has been more than 72 hours since the account was first upgraded and you have not received any notification, please reply to this ticket. If you would rather speak with a representative directly, please contact Account & Technical Services. Our contact information can be found at http://blizzard.com/support/article/cs."
Well well well,

Just got a idiotic reply from Blizzard team few minutes ago regarding the update of this issue,

Gaedhildite Customer Service Representative

Hail!Thanks for contacting us about your game.
I've checked everything over, and see that your network and graphics drivers are a year old. Each version of our games are based on current drivers. Please update them and send us a new MSINFO if you still have trouble with the game.Let us know if you have other questions.

Best RegardsRep.
Account & Technical Service Customer Services
Blizzard Entertainmentwww.blizzard.com/support

I am very very disappointed with this reply, don't they think carefully before answer any of their valuable customer issue?? How come they keep creating problem and the way Blizzard Team resolve this issue is such a "legendary" method!!
I've change my password again today and it's shown Full version finally.
Good luck
same problem but gone as far as locking account and unlocking password change and email change uninstall and re-install 3 times but to no avail no one can help me system clock is right i am trying to join us servers (i think mine is caused by hots)
Just got on to play some random custom maps and got the 'upgrade now and unlock' popup. I clicked 'upgrade now' to see if that would fix the problem, and it prompted me to change my password, claiming there was some security concern. I did so, quit and logged in with my new information, and the pop up still shows up. This is very frustrating and unsatisfactory.

Edit: I would note that this is with WOL not HOTS.
Blizzard please read this thread and fix this problem!! I am on US server and running into the same issue!!

Join the Conversation

Return to Forum