Mac OS X 10.6 for Heart of the Swarm

Mac Technical Support
I know that Blizzard will no longer support 10.6 for Heart of the Swarm, but will I still be able to use 10.6 and just forego any technical support that I may require. I've heard nothing but horror stories about upgrading from 10.6 to 10.7 or 10.8. It seems to turn perfectly running systems into horridly slow pieces of junk and I really don't want to ruin my iMac like I ruined my iPhone 3G with that iOS update a few years back.

Please respond Blizzard, thanks in advance.
For what it's worth, I updated from 10.6 to 10.8 last week on my 2011 MBP and it's working just fine. As for 10.6 support, I don't think you will be able to play, as the latest patch is required if you are to log in and play with others online.
So ends being able to play BW and SC2 on the same version of the OS.
I was able to play the beta just fine before they broke the game for it back in December, but we'll probably have to update. I'm still on 10.6.8 and not looking forward to the trouble that the OS update is probably going to cause me.
Hmm, I'm able to play the new patch just fine(10.6.8). It just yells at me every time I launch the game.
Don't fear the Mountain Lion.
01/26/2013 09:48 PMPosted by SoulWager
Hmm, I'm able to play the new patch just fine(10.6.8). It just yells at me every time I launch the game.


Support won't be dropped until the release of HOTS/patch 2.0 for WOL

01/27/2013 07:54 AMPosted by JimBond
Don't fear the Mountain Lion.


+1

Mountain Lion is quite nice.
For what it's worth.


Lion and Mountain Lion sucks, I have 8GB of RAM and it's not enough for these OS, I'm going back to Snow Leopard, solid OS.
01/27/2013 07:54 AMPosted by JimBond
Don't fear the Mountain Lion.

Agreed, playing both WoL and HoTS with no problems on 10.8.2 :)
Some additional details about Mac OS X 10.6 systems and StarCraft II Wings of Liberty 2.0/Heart of the Swarm:

  • Players with Mac OS X 10.6 will still be able to patch and play both Wings of Liberty and Heart of the Swarm; however, we are dropping support for that OS and any bugs caused by that OS may not be fixed.
  • We will be unable to assist with technical support issues caused by the use of Mac OS X 10.6. We recommend upgrading to the newest OS to ensure the best compatibility with Wings of Liberty post patch 2.0 and for Heart of the Swarm.
Thanks for clearing this up! I guess I'll just try to finish the game before there are too many patch updates that might break the game (1.5 was very hard to get working). This saves on getting a new OS just to play a video game. Some of us do other things besides SC2 on our macs :)
02/10/2013 11:08 AMPosted by Soundwave
Some of us do other things besides SC2 on our macs :)

Like play World of Warcraft or Diablo III?

;)
@Machkhan, while it may be fine to joke around to those of us who for whatever reasons do not (or are unable to) upgrade our systems, the fact is that we bought SC2:WOL to work in OSX.6.8 and IT DID WORK. It worked just fine until Blizzard altered it so much that our systems couldn't open it.

This is happening for some of us, MANY OF US; (ME in particular,) have found that WOL won't even open anymore in X.6.8.
I paid for a game that worked but now it does not. That's all on Blizzard...
Expecting people to upgrade their OS all for Starcraft is a bit presumptuous I'd say.
I opened a Support Ticket with your Support staff and so far, nothing has made the game work. All I want to do is play against the AI. I don't care about playing others.

I played the original SC back in the day and really liked SC2.
The fact that I can still play SC1 on my 2009 MacPro with NO issue supports the fact that Blizzard is accountable for fixing SC2 so that it works (albeit limited,) on our systems.
My 10 year old son wants HOTS for his new Windows 8 PC but I am apprehensive in buying it for him. I mean, what's gonna happen in 2 years when his PC gets a little older? Will HOTS just stop working on his computer as well?
Is Blizzard going to refund ALL MY MONEY for games that no longer function due to Blizzard's over-tweaking?
Hey Striker,

I'm locking this thread as it is getting off topic. If you wish to provide feedback about the Mac OS X 10.6 support changes, please post in our sticky that developement is reading.

If you have an issue that is occurring that is preventing you from playing, please create a thread with the information at hand regarding the issue.

We can try to troubleshoot the issue to see if there are other things that are causing the game not to launch. AFAIK, you should be able to play still, but if the issue/bug is determined to be caused by the OS itself, this is something that won't be updated.

Join the Conversation

Return to Forum