HOTS Game client version mismatch...

Technical Support
With the new patch..the launcher downloaded full 8GB -_-
The main menu complains "Game client version mismatch with selected region" and I can't login. This is weird because there aren't multiple regions for hots afaik ?
ME TOO! EXACTLY the same problem. For some reason, the patch info from the HOTS beta game client says it's downloading WOL patch 1.54! AND IT'S DOWNLOADING ALL 8GB on the HOTS beta client!

ALSO, when I try to play WOL, it says it's up to date even though i KNOW it's NOT! Blizzard please fix this! PLEASE. This is ridiculous! :(
Did either of you preorder earlier this month? I am running in to this same issue. I was able to play all week, HOTS shows up in my account but I believe the beta needs to also be listed to actually have beta access...
Happened to me too, I pre ordered earlier this month and could log into beta. My SC2 WOL got messed up as well, saying region mismatch and then language mismatch. I fixed WOL but haven't been able to fix HOTS, looks like beta access was removed.
This has happened to me too. Although my WOL is fine.
Same here.... Blizzard has taken our beta access away, I want my money back until HoTS comes out :/. I feel cheated.
I Pre-Ordered several weeks ago too, and still no official beta invite either, I thought they said they would be sending them out weekly to people that Pre-Purchased HoTS.. I guess not.
I can't believe Blizzard is ignoring us. There are 4 or more threads active on these forums on this issue.
I was able to play HOTS until last night (Jan. 24th). I am also getting the "Game client version mismatch with selected region" message, and cannot log in to HOTS. WOL is working fine.
I have the same problem! o/
Hello Everyone, we're looking into this issue, and I'll post updates as I get them. Thanks for your patience!
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
yargh! ty for being quick about it though
yes i am also having this issue, very dissapointed. Ive been on chat help and opened tickets etc etc and i was just directed to this thread
01/25/2013 12:56 AMPosted by DarK
"Game client version mismatch with selected region"


I am also getting the "Game client version mismatch with selected region" message, and cannot log in to HOTS. WOL is working fine.

Ok, just to be thorough, after this message comes up, do you click Ok, and try to log into the HotS beta again?

Also, could you screenshot this error message and post it?
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
yes I have tried hitting "ok" and just signing in but the error persists and does not let you sign in. Unlike in WOL, when I was having the mismatch error... in WOL you are able to hit "ok" and continue to log in and it works. Although this is not the same for HOTS
how do i post screens? can't seem to figure it out haha
Same thing happened to me, has anyone downloaded the full 8gb to see if HotS works after it? Guess not because of the whole region mismatch thing.
from what I understand not everyone is effected? I was watching some streamers earlier this morning
screenshot of error: http://imgur.com/hPdBBxI
Hots is fully downloaded
happens regardless of server choice (SCII-1 or SCII-2)
WoL works just fine

Join the Conversation

Return to Forum