"cannot start because icuuc44.dll is missing"

Technical Support
Windows 8 64-bit.

A week ago, my WoL client stopped showing any options for quick match. It looked exactly like this screenshot: http://i.imgur.com/ykh9oWi.jpg

I thought it was a network or battlenet anomoly. I waited some days, but it never fixed.

I uninstalled sc2, reinstalled using the installer from my bnet account page.

During the install, it got to the "playable" state, and I was concerned because it was not in the start menu, and when I clicked "Play", it gave the following message:

SC2.exe - System Error
The program can't start because icuuc44.dll is missing from your computer. Try reinstalling the program to fix this problem.

I let it continue, downloading the entire >8gb content before trying again. Same message. Tried "Repair Tool" which did nothing.

I did notice that in my "Support" folder there are only the following files:
  • Battle.net.dll
  • BlizzardError.exe
  • PrePopulateCache.exe
  • SC2Editor.exe
  • SC2Switcher.exe
  • When I know there used to be many more.

    Please help. I want to play this game but after 2 years all the sudden it doesn't install.
    having the same issue... don't know what the heck is going on :(
    ... i fixed this by 1) opening a support ticket instead of using this forum, 2) uninstalling sc2 completely. I don't know exactly which files caused the problem, but the relevant article is here:


    However after re-installing the quick match buttons are still gone. ARG.
    Having all of the OP's issues since last update
    right click ur launcher, compatability mode set to windows 7 and run as admin. this worked for me. also try to use the repair tool in the launcher. cheers
    I don't know if this will work for anyone else but I am posting how I resolved it because it took me 3 days and countless ulcers. I uninstalled the game initially and then when I tried to reinstall from the digital download section on the website it gave me the "CANNOT START BECAUSE ICUUC44.DLL IS MISSING"

    I tried switching users, disabling anti-virus, appending certain texts to the path name in the environment variables, closing background applications, running the repair, etc and nothing worked. Essentially I went to
    -----> Start
    In the search section type "C:\Program" and you'll get the option that says Program Files (x86). Click that, and scroll through and you'll see a Starcraft folder somewhere there. I deleted the entire folder. It'll remove Starcraft 2 entirely, but I believe when I uninstalled it the first time it didn't remove it properly. Anyway, delete that whole folder. It will delete everything to do with SC2 on your computer, download the digital version from the website, run the repair tool before you hit Play, and then go for it.

    Again, this is only what worked for me when nothing else did, and it's not a pretty fix, but it worked for me. Good luck with your suffering.

    Join the Conversation

    Return to Forum