All Arcade games unplayable !!! NZ

Technical Support
Arcade mode is broken please help.

It started with some game titles appearing as ... and no graphics images in all sections like Recently played, Open games etc. The bookmarks section would not open.

So I Deleted the Cache Folder (PC) as per your self help section.. Deleted the "C:\ProgramData\Blizzard Entertainment folder.

Now everything in Arcade is displayed as ... in all sections including Spotlight.

How do I fix this ?
Same. Stuck at streaming data. I used the DNS fix as I was unable to even log in before I got the other error.

Cannot even play it offline still.................... SC2 expack.. No thanks
Bump ....
The only option i have in arcade is to play "Fun or Not" and it responds with the error

The only option i have in arcade is to play "Fun or Not" and it responds with the error


Yep had the exact same error message.

I contacted blizz I was told to delete the blizzard entertainment folder. Did that and now get pinned with this error message at login.

Login Error
The authentication module provided by the service is corrupt. Please try again.

Repaired, uninstalled, reinstalled, patched and optimized with no such luck.

Something happened with the latest patch.
Yeah I have the ... things happening too.
Bump.. Still not fixed
Yeah I have the same error.
Bump ... Still no resolution and cannot play Starcraft
not sure if this helps you guys but i fixed it by just flushing my dns cache and setting my dns to google's secondary,
good luck
Thanks for the suggestion pathe, pointing my dns resolution to a public DNS like googles is not a solution i would ever try.

I would ask why googles dns server resolves names to different ip's than the rest of the worlds dns servers. But i dont need the answer..

Still no resolution and cannot play starcraft
had the same error, tried everything, nothing worked D: i want to play
I had the same problem, searched for solutions, the only one that worked was the following:

- Download Hotspot Shield (Proxy prorgram)
- Run Hotspot Shield when i play sc2, once i play the few maps i want to play
- Close Hotspot Shield after I have played a few games of the ones i want to
- Works now... only after doing this... stupid...
Having the same problem right now, cant open bookmarks, some games on the top 10 are not even showing up.
same problem here.


changing DNS servers to googles doesnt work for me.
Just a question I want to find out here: Are you all SEA users playing on NA? I've heard there might be a correlation there. I'm a SEA user on NA but it seems that I might not be affected because I'm using a region switcher to switch between regions(since i also have an EU acc). Just wanted to find out of this only affects those with the SEA client and not NA client.

I'm a SEA user playing on NA and so far all my SEA friends are having the same problems where they cant see some arcades. This should hopefully be fixed soon considering it's quite a big problem affecting probably all of the SEA players.

Edit: A temporary solution to this problem is to get an updated version of the Blizzard Entertainment folder located in Program Data on your C drive. This will allow you to play ladder games and some customs until they update again. Go here to page 4 and read DarkCrescents post where you can get the link to an updated version of it.
Bump... still not working
Still not working , what is the newest way to fix this ???

Join the Conversation

Return to Forum