All Arcade games unplayable !!! NZ

Technical Support
I have this too, tried all the DNS changes suggested but made no diff. Not sure I'll be getting Heart of the Swarm as these kind of issue are way too common with this game.
Bump still not working.. Come on blizzard this is crap support
its been a week ,now , can not play quick match . this is crap . !!!
Me too.
Almost half of arcade games show "...." .
Come on blizzard , Fix it.
Dont let the technical support forum become a bull !@#$ support.
me2 i cant paly anything what's !@#$ing wrong with blizzard
Same issue here. Cant even submit a support ticket.

Would be nice if someone from Blizzard support would at least acknowledge this thread since its been a problem for over a week.

Getting tired of all these issues with the game!
Well there is a ! button on the top right corner of the arcade game your playing clicking that might be able to get blizzards or the person who made the arcade game to notice.
still not working, bump
I have the same exact problem. I've been having trouble for about 3 days now... something must've happened to their servers
I am having this problem too, only certain arcade games don't show up. The ones that do work fine. Also, the whole Arcade screen is laggy as hell for me.

Join the Conversation

Return to Forum