Fix for recent errors in WOL

Technical Support
Hello, there has been a upsurge of errors in WOL (not sure about HOTS) like - Download authentication module error, Find match greyed out, Clientside cache error etc

Fortunately there is a simple fix for all these things.

1. Download Hotspot shield (search in google)
2. Install and run it
3. Start SC2 (Wings of liberty)
4. If the issue was authentication module error it would be resolved automatically now.
5. If you couldn't download maps before (ladder or custom games), you can download it now.
6. After all this is done, quit SC2, uninstall hotspot shield and start SC2 normally like before.

This thread is for those who are still waiting to play the game and dont know this fix. To all those who know, good for you :D
LEGEND someone promote this man to blizzard admin
Thanks Kimmy xD
thanks Harbiger
Thank you very much!
Fixed my problem!
Hi Harbinger,

I did what you instructed above. It worked while hotspot shield was active, subsequently after uninstalling the hotspot shield, when i tried it again, it went back to square one where entering some maps would give me the cache_file_cannotbe read error.

Is there something I missed out perhaps?
Unfortunately this is just a temporary fix, you need to have hotspot on to download any map you wish to play, once downloaded though, you can play the downloaded map(s) without the hotspot :)
Thanks Harbinger. Unfortunately it is not a permanent fix to the problem, but it is a good work around while Blizzard figures out a real solution.
FAAARRRKIN LEGENNNNND!!!!
i always get the error message :
CLIENTSIDECACHE_READ_FILE_NOT_LOCAL

i cannot see the race or difficulty in multiplayer or play games in single player!
all that works is the campaign..

will this help my problem?
i always get the error message :
CLIENTSIDECACHE_READ_FILE_NOT_LOCAL

i cannot see the race or difficulty in multiplayer or play games in single player!
all that works is the campaign..

will this help my problem?


Yes follow the steps, it should work !
it si okay if i stuck in initializing data screen?
it just froze after i clicked the connect button
This helped me get past login , as i was having authentication module error. now i can't see race or difficulty in multiplayer :(
i download the map using this but then a while into any game type my net crashes and this has only ever happened to me on starcraft
I haven't tried using Hotspot Shield, but for some other workarounds see http://us.battle.net/sc2/en/forum/topic/7708411977?page=5#89
Awesome !!
It didn't work for me:(((
Says "unable to download an authentication module" :((
You're amazing Harbinger, thanks so much!

I'd tried everything recommended by Blizz support, but that was no help at all, only made things worse in fact. Before I was instructed to delete the folders in ProgramData, the multiplayer screens would just be blank, and then after deletion, the authentication module issue appeared.

The inability to play multiplayer games wasn't a problem until after the most recent update. They messed something up and clearly haven't been able to fix it yet or know wtf is going on (as evidenced by support's ineptitude). One would think that after weeks/months of problems that they'd release a new patch... fwiw, I'm in Asia.

Thanks again Harbinger, you're the man (or woman? haha).
Harbringer, you saved me. Make him a MVP!!!!!

Join the Conversation

Return to Forum