Starcraft 2 Authorised Language Problem

Mac Technical Support
I currently live in Taiwan (TW). I recently purchased the NA version of Starcraft 2 and installed it on my computer. But whenever I try to log in. It tells me that I need to have an authorised language pack from blizzard. However I tried to follow the steps on the forums, such as changing the variables.txt but that didn't work for me. However I'm able to play HOTS beta. But I cant play wings of liberty. Also I tried to change the local stuff in variables.txt into zhTW (where I live) and I'm able to log in successfully in wings of liberty. Everything is in chinese but the game is working. WHY??? I WANT TO PLAY IN ENGLISH!!! but when I change it back to enUS the same error message pops up saying that I need an authorised language pack. What should I do? Can anyone help me? Blizzard's support tickets not replying
This is something that is not currently supported. In order to play the game in a specific language, you will need to have a license that is from that region.

This is something that is currently being reviewed based on feedback. Should anything change, we will post updates.
I know that you can only play in the region you bought. But I have the valid licence of the NA server that I purchased in battle.net and I want to play in NA region. I also have the TW version. I removed my TW version of the game from the computer and downloaded the NA client from battle.net so I can play the NA version of the game
@leoku You are not alone :)

I also encountered the same problem with the same situation.
you need just same your different versions in different named folders.

Such as:

TW version in (TW Starcraft)

NA version in (NA Starcraft)
This is happening to me too. Traditional Chinese... I cant read it and its effecting my will to play this game.

Join the Conversation

Return to Forum