"Updating Blizzard launcher" game wont launch

Technical Support
Starcraft has worked fine the whole time i have owned it since it came out. but now when i try to open it, a download starts for a patch or something and then it gets stuck at about 70 percent. The only thing it says is "updating blizzard launcher..."

Has anyone else had this problem before or know what to do?

Btw: I played the day or so before this happened. so there weren't a bunch of patches i am backed up on downloading. I dont think a patch has even been released in the last week.
AnTibiotic, these suggestions may help with this issue. Let us know it goes, and we can work from there.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
Ok it worked. not sure which change was the deciding factor. In one of the later ones, maybe the advanced troubleshooting section. Thanks
I had the same problem the suggestions by velnrak made it work for me. I only did step 5 which was deleting the Battle.net Tools folder because I knew the other suggestions wouldn't apply to my computer.
Thanks.
How do I delete the Battle.net Tools folder with Windows 8?
If you just start typing this, it should appear in the Start Menu search:
c:\programdata
Then delete the Battle.net folder. If that doesn't help, delete the Blizzard Entertainment folder as well.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
it wont let me delete it
energystar, try restarting your computer, and then see if you can delete the Battle.net folder.
________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
none of it worked for me. Any other suggestions?
All the tips on this website have helped me out a lot when i encounter starcraft problems. THanks to all the people who put the !@#$ up here to tell me how to fix it. Saving me hours of time and frustration.

Join the Conversation

Return to Forum