Rewards are currently unavailable+no conten

Bug Report
Guys, I haven't play SC2 for a long time and I recently decided to play again, but strangely I can't change my portrait, cause when i click on profile then rewards then portraits the game just say Error, Rewards are currently unavailable.

Another problem is that I can't play anything other than campaign. I click on quick match I can only select the difficulty and nothing else. I click on Custom Games or V.S. A.I. it just says No content found.

Can anyone else provide me a fix? I tried reinstalling the game and I still has this problem.
Me too.
Can someone please provide a fix?
Same here, Am has the same problem as you guys.
although mine does not say "Error, Rewards are currently unavailable."
its just shows nothing.
By the way, my Sea account works fine.
The reason I prefer to be in NA is because the population in SEA is pretty limited, it is kinda hard for me to play with someone on the equal level of strength. I'll try SEA in a moment.
Try this changing your dns
for some reason the only one that worked for me was this one->For IPv4:

Join the Conversation

Return to Forum