Game won't launch unless I launch TF2

Technical Support
It sounds weird, I know! I built a new computer over the summer, and when I installed SC2 it just would not launch. The launcher would go away, I'd get that 'busy' blue circle for my cursor from Windows 7...then it would stop. The cursor would go away and the computer would run like nothing was happening. The task manager showed SC2 as running, but there was no program opening up. It was not a waiting issue, I did that, went to work, and came home to the same condition.

I opened a ticket with support and it didn't seem to help. I reinstalled several times, I moved the game from my solid state hard drive to my disc hard drive, and the same thing happened. It seemed that all was lost! And then, by chance, one day I launched TF2 from steam after I had tried to open SC2...and you know what? SC2 opened! It opened up along side TF2. My mind was boggled, to say the least.

Anyway, that's how I've been working around my issue since about August. I figured it would change up once HotS came out, but I just got into the beta and the same thing happens with this launcher! I figured it was time to air this out in public and see if anyone has any idea on what might be going down.
Oh, and one more thing: I have tried launching other games from steam, but they don't seem to have the same effect. It was not an exhaustive attempt, but I tried about four other games from my list and they would not do it.
BigJimSlade, I would investigate any background program interference first, and try a Selective Startup.

I would also reset the cache, as well as the Blizzard Entertainment folder.
Monday - Friday, 8 am - 5 pm PST

Join the Conversation

Return to Forum