Setting Mouse Controls Broken?

Mac Technical Support
I used to be able to link my Logitech mouse to Starcraft II, but now it seems that every time I try to set it up when I open the program it says Diablo III Setup!
I do not have this problem with Diablo III nor World of Warcraft.
So what has changed.
Neither of my Logitech mice, wired optical (old) and wireless (newer) will select Starcraft when double clicking it, yet both will select ANY other program properly.
Thus, whatever it is is inside Starcraft II now.
Are you opening it from a desktop shortcut, dock icon or in the StarCraft II folder in Finder?

This is the first time I've seen this kind of issue.
OK, Logitech Control Center - have old Logitech wired Optical mouse and newer wireless mouse. I have custom setups for various programs without issue.
Also have Nostromo n52te game pad, set up for WoW, but never could set it up for Starcraft, either I or II. Would love to use it, but been without.

Current issue, with adding a setup one goes to System Prefs, LCC, clicks on mouse then Configure.

In there you have General and Buttons. In Buttons you have a pop up menu with a Plus/Minus. So you click popup menu, to see what has been set up, or if you click Plus, an Open File dialog appears. You navigate to the programs you want to add, select it, then click Open - or simply double click the file. Just as if you were opening a file in any program.

However, for Starcraft II now it comes up Diablo III Launcher despite the fact that app is not even inside or near the Starcraft II folder!

In the past, not long ago, I had my old Optical mouse set up so the middle button was Command Click, easier than hitting M or A and clicking. If the Game pad was recognized this wouldn't be a problem, but it has never been recognized. (strange, Blizzard does all 3 games, guess developers don't talk to each other).

So now I cannot use the mouse the way I want to. And I posted the issue.
I had a similar issue on my previous computer, where whenever I tried to add a custom configuration for SC2, the utility would switch to SC2 Editor.

Yesterday, I got a new iMac and I am somehow able to select the SC2 app but my custom configuration doesn't work. I can create a custom configuration for any other app on my computer, but I can't do it for SC2... It seems like the app I am selecting in Finder isn't the app that ultimately ends up running when I am playing the game (or at least that's the only thing I can think of that might be causing this).
Interesting, especially since I am not the only one. I know, 2 doesn't make it a big deal, but maybe there are others out there and they either don't know they have this problem or they aren't using the LCC to modify their mouse settings per program.
I also tried other selecting of programs, and all others come up just fine. There is nothing wrong with my WoW or Company of Heroes or Safari or Diablo III settings.
Also of note, while looking through the ~/Library/Preferences...
There are a series of com.logitech. files. One is called assignments. It holds the application links.
Searching through tat I found ...


That last had key assignments, and was probably the one not named properly for the actual application chosen, Starcraft II or shown as Diablo III Launcher!

My guess is that the program's name is somehow being read as bootstrap. Question is why. As there is a proper reference to Starcraft II in a different plist file for logitech.
!! I found it !!

And it is from Blizzard.

Looked in the package contents, there is an info.plist. All programs have this. And in this file there is a bundle identifier piece of data.

In World of Warcraft, that is com.blizzard.worldofwarcraft-64.
In Diablo III it is com.blizzard.diabloIII
However, in StarCraft it is com.blizzard.bootstrap.

Does your config work now, then? My assignments file was set to "bootstrapper" (which is the name listed in my info.plist), but my custom configuration still won't work for SC2...
Solved it! Okay, so I figured that the actual SC2 process had a different name, and I used terminal to find out the location of the actual program by running the following command (while the game was actually running):

ps -ax | grep 'StarCraft II'

This revealed that the actual program was located in the following directory:

/Applications/StarCraft II/Versions/Base23260/

However, "Versions" is a package, so you can't navigate there with the LCC interface. As a workaround, I copied the SC2 file located in that directory to an accessible folder. I then used the LCC utility to add a profile for the copy. That profile is working for the regular app (even after deleting the copy I created).

However, I wouldn't be surprised if I have to go through this process again each time SC2 is patched...
Which is why this should be fixed.
And no, it still isn't working for the remapped mouse.
I am loath to muck around with stuff that I SHOULD NOT need to muck around with.
Can I do it, yes. And if it fails or messes my install up, guess who is gonna point the finger and refuse to do anything.
I will also bet that this silliness is why the Nostromo n52te doesn't work in SC II.
BTW - thanks for the location of the actual program - called SCII.
LCC was able to see a copy of that I pulled out from the package contents and appear to set things up, will need to test.

And yes turkeykramer, it will need to be redone each update given what I see in the Versions package.

Again, we SHOULD NOT have to do this for something that should be easily allowed and done.
OK, that did work, gonna try that with my Nostromo and see if that will work also. If it does, great. If not, oh well.
And lastly, the Nostromo Game Pad now works.
Of course, I have to remember what I set the various keys to, but it works.

Thanks again turkeykramer for the direction from seeing what is actually running.
Well, your initial comments were what gave me the idea on where to look, so I consider it a community effort. :) I'm glad we found a workaround, but I hope this is something that can be easily resolved by Blizzard. I imagine we aren't the only ones trying to create custom hardware configurations for SC2.

Join the Conversation

Return to Forum