Can't launch Starcraft 2

Mac Technical Support

This morning my SC2 (non-HOTS) client finished downloading the new 2.0 patch. When I went to open the SC2 launcher, it got stuck at "Updating Blizzard Launcher". I left it for about 15 minutes, and it stayed stuck at about 70% complete.

After reading around on these forums, I deleted the /Users/Shared/ folder, and re-launched the SC2 launcher. Now the launcher is stuck at "Updating Blizzard Update Agent..." with about 30% complete. It's been at this stage for about 15 minutes.

I'm running 10.8.2 and have been playing SC2 for a couple of years, never having had an issue like this. Anyone have any thoughts?

Try doing this to see if it helps in any way.

    1. Navigate to /Users/Shared/
    2. Open Agent.db with TextEdit.
    3. Press Command-A to select all text and delete the contents.
    4. Copy/Paste the following into the file and save it:
    "/option" : {
    "resource" : {
    "optionroot" : {
    "p2penable" : false,
    "ignorespeedtest" : false
    "links" : [
    5. Run the Launcher.

This disables P2P (peer-to-peer) and has been known to resolve these issues in the past.

Thanks for the suggestion. Unfortunately, this did not do anything to solve the problem. Still exact same as first post.

Replacing what was in agent.db fixed the problem for me. Still had to wait 1-2 mins but it launched after that
Same issue, fix doesn't work.
Can you post your system specs, Dino?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
Hi i couldnt Log into my game as well!!!!!
it just stay in Starcraft II Launcher : Updating Blizzard Launcher.,,,

machkhan's posted the same fix in several forums that dont work so thx blizz for nothin
You think blizzard would have someone monitor these forums because a ton of people are having the same problem. I had this same exact issue which I resolved on my PC only by directly connecting to my router via ethernet. Now I am having the same issue on my MacBook. I have not yet tried directly connecting this time. There should be an easier way though. There is no reason why wireless internet isn't good enough.
Why cant i launch SC2 when it is in the yellow? It says that it failed to launch.
Hey--this issue was plaguing me big time, right after I upgraded to Mavericks. Whenever i started the SC Installer, my entire iMac would freeze-up and force a complete shutdown and restart. I wasn't even able to kill the locked SC installer via Force Quite.

Fortunately, I found this post from machkahn and it worked like a charm. Replacing the contents of the Agent.db file was the only thing i tried that actually got the Installer to stop locking and thereby freezing my entire desktop.

The fix that Machkhan posted did not work for me. I also repaired my disk permissions as well. Unable to play Starcraft 2 at this point.
Hey running into a similar issue. I've downloaded the Digital Copy of SC2, so that I could buy HoS, but I keep getting THIS message when I try to press the play button. "Failed to launch a critical file. Please close all other application, temporally disable your security software or log in as an administrator and try again."

I've done all of that; I have ZERO other applications open, I don't even think I have anti-virus software on here and I created a user account specifically to do this. Anyone one have any suggestions?

Join the Conversation

Return to Forum