Failed to download information about next

Mac Technical Support
About a month ago, whenever I would go to the launcher menu and had my internet connection on, it would idle forever and never be available to play. It never said there was a patch to download or anything. When I tried the launcher when I was offline it would work fine. So I would start launcher offline, and then before I pressed play I would turn internet on...and then I could play online. All of the sudden last night I was playing online, went to do something else, and then tried to get back online...but now when I'm offline and trying to launch the game it shows the message ..."Failed to download info about next patch, please check your internet connection"....And when I try to launch the game when I am already online, it just idles forever and never does anything. I have repaired disk permissions as other threads suggested, checked that I am admin, checked that the files say read and write....I've pretty much done everything every other thread has suggested. I do have the op system for mac that will be outdated for the new expansion, and was planning on getting it this the problem, has a patch already come out that no longer supports my OP?
This sounds like it is using an old version of patching tools (pre-patch 1.5). What version of Mac OS X are you running?
I am getting the same prompt and I just updated to the most recent OS X
Are you running an older version of the game (1.4.x and below)?

Join the Conversation

Return to Forum