Profile problems

Technical Support
Hello. I don't know if this is the correct forum.
I'm reinstalling the game. After a very long absence - early 2011. In preparation for HoTS launch. After the minimum download, I'm able to run the game and login. The issue is that this profile that you're seeing: Achievments, FoS, games played etc... is not showing.
It's like the very first time I logged in back when the WoL launched.

How can I solve this issue and get my profile, achievments, portraits back?
Thanks in advance.
Can I get an answer or any help about this please? I've just finished downloading all of the content and my profile's still missing. I don't know if it's of any help but I'm from Brazil.
So... Can I get any help.... Please?
Hi Minngs,

Based on what I can see on your account, the game key you claimed back in 2010 is a Latin American key.

Are you currently logging in to the Spanish or English game client?

Can you post a screenshot of your log in screen?
Hi Minngs,

Based on what I can see on your account, the game key you claimed back in 2010 is a Latin American key.

Are you currently logging in to the Spanish or English game client?

Can you post a screenshot of your log in screen?
/

Thank you for the reply roraks.

Yes. Since I'm Brazilian when I first purchased my SC2 it was from a retail box. If I do remember my client was at that time PT-BR. When I heard about the promotion that all the people who had bought the half-year long cd-key would be granted a permanent one I logged and checked it.

Since we're close to HoTS I only decided to reinstall now so I can upgrade for HoTS ASAP. I don't know if all this info is of any use. And yes, my client is US now.

Just a small question: where the screeenshots are located into my pc?
(old time gamer - but I suck big time with everything but games =P)

Thanks in advance and sry for the long reply.
I've just checked back into my account and I don't know why the basic download was set to English (EU). It's not even US. So. Should I just erase it all and download the PT-BR one? Or can I do download the English-US one?

Thanks
02/13/2013 06:28 PMPosted by Minngs
I've just checked back into my account and I don't know why the basic download was set to English (EU). It's not even US. So. Should I just erase it all and download the PT-BR one?
It definitely sounds like you have the European client.

The best solution will be to uninstall the current game client and reinstall the correct one.

Here's a direct link:

PC - PtBR
Mac - PtBR
02/14/2013 09:07 AMPosted by Roraks
I've just checked back into my account and I don't know why the basic download was set to English (EU). It's not even US. So. Should I just erase it all and download the PT-BR one?
It definitely sounds like you have the European client.

The best solution will be to uninstall the current game client and reinstall the correct one.

Here's a direct link:

[url="http://dist.blizzard.com/downloads/wow-installers/full/World-of-Warcraft-Setup-ptBR.exe"]PC - PtBR[/url]
[url="http://dist.blizzard.com/downloads/wow-installers/full/World-of-Warcraft-Setup-ptBR.zip"]Mac - PtBR[/url]


I'll do that and see if I can get my profile to work. If I can't get it back I'll refer to this thread.
Thanks Roraks. And sry for the trouble.

Join the Conversation

Return to Forum