Game freezes on campiagn level loading

Mac Technical Support
When playing campaigns and returning to the campaign hub map (Hyperion, with the armory/cantina/lab/bridge) after completing a level, the loading frequently stalls immediately after completing the Streaming Data stage. At the point where the loading bar is 50% filled, Starcraft 2 becomes non-responsive (does not even accept Cmd+M or Cmd+Tab to go to another window if in full-screen mode). If in windowed mode, the Force Quit Application window can be brought up with Cmd+Opt+Esc, and it marks SC2 as not responding.

This only appears to happen immediately after completing a campaign level. It does not seem to occur when entering the campaign hub map from the main Starcraft 2 menu. This issue does not happen 100% of the time; sometimes it loads just fine, although rarely.

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro9,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP91.00D3.B08
SMC Version (system): 2.1f173

Hardware UUID: 0C32E507-DD62-596F-87A9-23D0B72886D2
Sudden Motion Sensor:
State: Enabled

Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 384 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 1.9.23
Color LCD:
Display Type: LCD
Resolution: 1680 x 1050
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3682
gMux Version: 1.9.23

System Software Overview:

System Version: OS X 10.8.2 (12C3012)
Kernel Version: Darwin 12.2.1
Boot Volume: Macintosh HD
Boot Mode: Normal

Secure Virtual Memory: Enabled
Time since boot: 11 days 5:36

A quick search reveals the same issue being reported (with no solution provided) back in 2010.
Have you tried to delete the cache and repair StarCraft II? The way the game works now vs back then has changed significantly, so what happened in the past is something we can compare it to.
I'll try it, but I installed the game two days ago and this is happening.

Join the Conversation

Return to Forum