3rd Person Camera: Incorrect Yaw/Pitch Report

Editor Discussion
Tuesday's patch introduced an anomaly that essentially destroys any possibility for a third person game that involves aiming. Mine in particular depends on the functions called
Camera Yaw of Player
Camera Pitch of Player
to see exactly where the player is looking. Previously, these returned the exact values every time, but with latency in multiplayer, which is fine. Now, the return value of these functions appears to be "stuck" at one particular value until you've turned the camera over 15 degrees, at which it finally updates. I can understand if this was done intentionally to cut corners in performance and bandwidth, but it's unacceptable for a third person type of game and needs an option to be disabled.
I've looked in all the camera triggers and camera data fields and found nothing to address this.

You can easily test this by creating two triggers:

Game - Player Any Player types a chat message containing "-cam", matching Exactly
Local Variables
Camera - Lock camera mouse relative mode On for player (Triggering player)
Camera - Turn camera mouse rotation On for player (Triggering player)

Timer - Every 0.0 seconds of Game Time
Local Variables
UI - Display (Text((Current camera yaw of player 1)) with 2 decimal places) for (All players) to Subtitle area

Run the game, type -cam, and try turning the camera left and right. You'll see the inaccurate yaw reported on screen.

Edit: after testing this in a fresh map it seems to work fine. Must be something interfering in my main map. Will need to investigate the cause.

Edit 2: Even with every single trigger disabled, except the above two, it still happens. Must be some map setting that's different for new maps than old maps.

Edit 3: I crudely copied everything into another fresh map: units, points, regions, actors, units, behaviors, and finally triggers. Even though there are some trigger errors, it runs, and it reports the correct values for the camera yaw. I'll have to either finish copying the entire map over, or figure out what's the difference between the map settings that causes this.

Edit 4: Tried this in a few other maps. Looks like maps created before the patch have the same problem. I can't reproduce it in maps created after the patch. I also can't fix it in maps created before the patch.

Edit 5: After much headache and MPQ manipulation, I migrated my data and triggers to a new map so that it runs without errors. Then I copied over the regions, objects, and terrain files. Seems to work now.
I've noticed this glitch in one of my Third Person Shooter maps. Is there any quick fix? Or will I have to copy and paste everything over into a new map?

EDIT: Here's a solution : http://us.battle.net/sc2/en/forum/topic/7383598396
Thanks for link! It works now!
I looked at the link, but I don't know what solution you're talking about.

Join the Conversation

Return to Forum