2.0.4 Custom-Stuck on 'Entering Lobby'

Mac Technical Support
When creating a custom game of the last map I played before the update the game hangs on "entering lobby" which can not be cancelled without quitting the game. All other maps, including custom and stock blizzard maps, have errors downloading. Tried quitting/restarting app and osx, but there isn't much other diagnostic I know of. Any ideas? 10.8.2 on
What errors do you have when downloading? Screenshots will be helpful in determining this issue.

Have you also tried to clear out your Battle.net cache to see if it helps?
I'll answer my own question here, turns out removing the /users/shared/blizzard & battlenet files did the trick.
Will removing those files effect anything? I don't want all of my custom game stats to be erased or anything xD
Removing those Battle.net files will not affect your game stats, SiNistRSwarM. Once you've removed those, and restart the Battle.net app and StarCraft II, those cache files will be recreated fresh.

Rate me! https://www.surveymonkey.com/s/Velnrak

Join the Conversation

Return to Forum