"some dll files are missing" Install Error

Technical Support
We are aware of an issue that can occur when users uninstall the game without Delete save games and replays clicked and then attempt to reinstall the game. In these cases players will be told that files are missing and will not be able to play when they click on the Play button in the launcher.

There are two ways that this can be addressed if you are encountering this issue:
  • When you uninstall the game make sure to have Delete save games and replays selected.
  • If you want to save your save games, replays, map data, etc. uninstall with Delete save games and replays unselected and rename the folder containing these files so that the installer will not recognize them as existing from a previous installation. Then reinstall the game.

________________________________________________
Monday - Friday, 8 am - 5 pm PST
Pelinti
seriously blizzard u have !@#$ed so many things up for so many people who just want to play a game they played for. i cant even play sc2 now cus of this stupid random error and i have reinstalled it from the internet before u even wrote that message and atm i cant even delete sc2 again for some reason cus theres no uninstall sc2 in any of my sc2 folders. we have paid for this game so we can play not piss about fixing errors you constantly cause. we arnt all tech experts and we just want to play the game it shouldnt be up to us to fix these errors constantly and you should do much more to help people with these errors. sc2 isnt even fun at all its just the custom games im more interested in.
i just went into my program files and deleted the Starcraft 2 folder, trying to reinstall and download again.......... big head ache
Blizz, your aware that people will only find this retrospective fix after its too late to implement it right?
I just bought the deluxe package and I can't even install it right now. being with Rogers that kind of ticks me off because of all of my attempts I'm at like 1/2 my internet cap and this billing period only started 2 days ago. (that is also because I own every single mainstream blizzard game there is to own online with the addition of 2 Diablo 1 discs. wish I could get that running on windows 7. had to download them all over again because of a reformat due to unrelated issues).

Now I have to go to work and stop hacking away at the problem unsuccessfully =(.

Hope I get this one soon.
Got a new toy and can't use it... hate it when that happens.
I uninstalled the game again and I didn't get a message to delete save games and replays. When I clicked uninstall a message came up saying certain folders couldn't be deleted. So I found the Starcraft 2 folder and looked in "replays" and "saves" and they are empty.
currently downloading a 9gigabite file hope the full download works because i'm not receiving old error messages. literally turned back the clock on my computer hope this helps. aiming for 100% download. what size is the file i am installing?
i am prepared to restore factory settings if needed.
I am having the same issue with this as well. I have tried so many different ways to fix this and I don't understand why it is not working. I love this game, I love the story, I own some of the books but I feel like Blizzard really needs to work on it's games.
I found a much quicker way of fixing this, rather than reinstalling the whole game which takes about a day for me.
First, rename your saves folder. Then, go to you SC2 installation folder and remove the folders labeled "Campaigns" and "Mods", and put them somewhere else like your desktop. These are the folders that take a day to install because they're so big. Then delete the rest of your Starcraft 2 folder. Run the installer (remember to run as administrator just in case), and when you see the shortcut appear on your desktop, close the installer and drop the 2 folders from earlier back into the SC2 folder. Then just run the installer again and it'll give you all the right files at a fraction of the time it takes to reinstall.
This is the only quick solution that worked for me.
I created a Python script that deletes my Battle.net folder every time I play. Embarrassing implementation.
please help me when i press ´´play´´ it doesn´t start and says that the icuuc44.dll file is missing and it doesn´t install the game i just have the !@#$ing setup and i dont know what to do and i really want to play D:
We are all !@#$ out of luck because why again? I've been playing Blizzard games for at least the last 12 years of my life so I probably won't stop now, but they are doing some serious damage to their long time loyal customers. And anybody in business knows that long term customers are the ones who keep you around. Frustrated and disappointed. Maybe send some of us a free online copy so that we can uninstall this trash one and re-install a copy that might work? I just don't see my problem being resolved, ever. Because apparently it is up to me to fix and technical support is very lacking in their help. I guess I'm lucky I haven't purchased the expansion yet, boy would I be salty if I had!!!
Blizzard we love you and your games, so please do something for us!!!
Seriously Blizzard? I don't have fast internet so I have to wait a couple of days just to play the game I bought?
Same thing has happened with me. It doesn't give me any option to delete any saved games or replays, just a general uninstall. I have deleted all starcraft folders anyway, reinstalled and now reads 'internet connection is required to download file' when I'm on HOTS installation even though I'm clearly connected by Wi-fi, now by connected cable. I hope Blizzard reads this.
I am getting this same error message. I have deleted all of the SC2 related stuff I can find. It doesn't even act like it is trying to reinstall the game. It just acts like it is trying to download this patch again.
Wow really now I have to install the 13.9 GB's AGAIN after I already installed them. Since I love this game its no problem but really its a waste of time. gj Blizzard for telling me this earlier.
awesome.
yea man i want to play but i have the same issue. cannot extract required files from achrive. with the 0008 error code. come on look at all the people posting the same error. help us technical support. come on your useless

Join the Conversation

Return to Forum