Unable to download Authentication Module

Technical Support
Every time i try to log on sc2 I get the "unable to download authentication module" message, I also cannot log on WOW and no settings have changed since I played on both just a few hours ago. My internet works fine, and I have tried all options on the support website. Please help diagnose this problem.
Same error message. I just tried a few times. No changes.
Are you using Avast! Antivirus?
Are you using Avast! Antivirus?


Yes.
I'm having the same problem and yes, I'm using Avast! Antivirus. Is there a known issue with Avast and SC2?
Are you using Avast! Antivirus?

I am, and I'm also having the same problem as those above me. Suggestions?
If you are using Avast!:

1) Open the user interface
2) Go to Real-Time Shields (Tab on left side)
3) Go to Expert Settings
4) Go to Exclusions
5) At the bottom of the list, there will be an empty box to type in. Type C:\ProgramData\Blizzard Entertainment\Battle.net\Cache\36\b2\*.auth and then hit Enter.
6) Make sure all 3 checkboxes are marked.
7) Click OK, and exit.

Props to Zyzzy, the man who solved this problem.
Thanks JOHNNYVIX and Zyzzy, it worked perfectly for me!
same problem..how can i fix it?
Are you in SEA? If so, try http://us.battle.net/sc2/en/forum/topic/7708411977?page=5#89

If not, please make a new thread as this one is 3 years old!

Join the Conversation

Return to Forum