Starter Edition purchase bug

Hi everyone, I recently just bought StarCraft 2, the purchase was completed and when I log into my account it shows up and is listed as "Standard Edition" but when I enter the game and log in I am prompted to purchase the game again, then when I go back to the website, it still says that it is standard edition, is there a fix for this? I am an Australian player on the US server.
Exact same problem for me, bought it after I got home yesterday, my account page says it's Standard Edition not Starter Edition anymore and the transaction history says that the purchase is complete.. so.. what gives?
Same problem. I tried the fixes they've listed to no avail. I was finally told to sit tight for a few days while they try to iron things out. I'm not sure what's going on, but it's been a few days now that I've been unable to play.
Same thing here :C hopefully we get a response or a fix soon, i've been talking to people on the live webchat, the phone support and chucked a couple of support tickets in also, it seems they all have different opinions on whats going on , but the phone support says its a known issue at the moment and they are actively looking in to it. :P hopefully they get this sorted out before HOTS gets released :)
Same happen here.

Bought on 1st of March
Charged on 5th of March
still can't play today (10th of March)

I submit ticket but they are pretty useless on this issue.

It make me feel like they stole my money, or I havn't received what I paid for (starter edition is free, and I am already PAID for standard edition)
Still waiting =/
Also when I bought it my credit card got charged full amount instantly and said it was completed in an hour so there shouldn't be any problems with that at all >_>
Seriously Blizzard, this is ridiculous.
Same prob here.
Bought digital download on 9 Mar.
Transaction recorded as Completed (not Queued) 11 Mar.
Tried syncing clock, changing email and changing password - no luck.
Game still says it's a Starter edition, not the Standard edition.

Blizz, any idea what's wrong?
Just got a message saying "Your Starcraft 2 installation needs to be optimized. This may take 15-60 minutes"
Right after that there was a 90 MB patch or so BUT.
Still gives me the god damn Starter Edition message >________>
So !@#$ing annoying I want to play already
Yay! I'm in!

I guess the HOTS rollout had something to do with it. Also waited for the Optimisation, the Patch download, and had to change password.

But I'm in!

Watch out Zerg scum...death awaits...
Finally work, but only for SEA server.

still show starter edition if I choose NA server.

my account say it should be global edition ?
Bought digital bundle yesterday, installed okay but i too get this issue, so it would appear that if you make a new purchase of this game then you will be unable to play it as it will state you need to upgrade to the full version, despite paying $79.
Bought digitally as well yesterday. Unable to play campaign because it says starter edition instead of standard, as my account summary states.
I'm getting the same issue with the digital bundle. No matter which server I log into it will tell me I need to upgrade, despite having the transactions completed. It's rather frustrating.
Can anyone help me please? I am also facing the same problem, I am having starter version no matter which server I login, but in my account summary it shows that it is standard version. I paid for the game but I am unable to play it...
Same problem with me
Same problem for me. Its been a few weeks now. Feel like I've had my money stolen to be honest. Really not good enough. Anyone else still have the issue? I have tickets in but have only been told to sit tight...

Join the Conversation

Return to Forum