Failed to download File

Technical Support
after waiting for the the blizzard updater for more than an hour, I get to the install screen. So I click the install button, and then have to wait another hour. Then finally a message pops up stating,

Failed to download a required installation file
( Please check your internet connection and try again.

I have tried reinstalling several time, replacing files, restarting my computer, updating my computer, and several other types of attempts, until i got this. I've tried installing from the installer on the site and from the physical CD Copy from EB Games. How can I fix this? I just want to at least play the campaign and continue the story.

I have also tried manually typing that site and going there directly, and the first time I tried that, I got a "File Not Found" or something like that. Now I've tried a second time and got this.

"product": "S2",
"install_progress_percent": 70.0,
"install_progress_info": [6000000000.0, 1000000000.0, 1400000000.0],
"download_progress_info": [10000000.0, 500000000.0, 5000000000.0],
"install_progress_speed": 5000000.0,
"updater_product": "s2_patch",
"expansion_level" : 1.000000,
"migration_required_build" : 21029.0,
"ptr": false,
"beta": false,
"update_method": "patch on demand",
"supports_multibox": false,
"supports_offline": true,
"data_dir": "Updates/",
"patch_url": "",
"update_regex" : "(?P<prefix>s2-update-(?P<dataset>\\w+))-(?P<build>\\d+)\\.mpq$",
"update_identifier": "s2-update-",
"torrent_file_path": "StarCraft II.tfil",
"manifest_file_path": "StarCraft II.mfil",
"priority_file_path": "StarCraft II.pfil",
"priority_file_layout": "Retail",
"binary_version_path": "Support/SC2Switcher.exe",
"supported_locales" : ["enUS", "esMX", "ptBR", "enGB", "deDE", "esES", "frFR", "itIT", "plPL", "ruRU", "koKR", "zhTW", "zhCN"],
"binary_launch_path": "Support/SC2Switcher.exe",
"switcher" : true,
"fullpath_hash": true,
"form": {
"eula": {
"game_dir": {
"default": "Program Files",
"dirname": "StarCraft II",
"required_space": 10100000000
"language": {
"authentication_key": {
"url": [

Please, can someone help me? Or is there some kind of fix for this? Or is there something wrong with my CD copy?
Try opening up task manager and seeing if there are any instances of agent running. Turn those off then try again.

Another program may be interfering. Try running a selective startup to get around this. Please be aware that running while in this mode can potentially disable any security programs you may have running.

Hold the Windows key on your keyboard and press the letter 'R'. In the Run field type "msconfig" and hit Enter.
In the General tab:

1. Choose Selective Startup
2. Disable (uncheck) Load startup items
3. Click OK and Reboot

To undo selective startup, just recheck Load startup items.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
If you have McAfee installed, you need to either give Agent.exe full access to the network on McAfee's firewall or just uninstall McAfee.
I tried you solution, and the blizzard updater works really quickly took only about a minute. However after that, I click the Install button, and it greys out. After a short while, This message pops up.

Failed to download arequired installation file []. Please check your internet connection and try again. I use a LAN wire and have check my internet connect and there is nothing wrong with it as far as I can tell. I've tried resetting my router and modem too and it still hasn't worked.

I have also once again tried, from the physical copy and from the downloaded setup

Am I missing something or is there something else I can try? or is there something wrong with the server?
Well this is kind of a shot in the dark but maybe

Went to Control Panel,
network and internet,
internet options,
LAN settings,
and disabled "detect settings automatically. Hope that helps.
I tried this and same thing, nothing has changed
I'm having this same error, and after following the steps outlined in this thread, have come to no solution. I've tried it on two seperate machines, and both have encountered the issue.
What kind of security software/router do you guys have?
I have AVG and I have tried shutting down all of my firewall and the entire program as well.
My internet uses Telus Actiontec Model V1000H.
You get that error using the WoL DVD, right? What error do you get if you use the installer from or the HotS dvd?
i installed WoL from CD. It installs fine and everything, then 1 of 24 updates come and it closes on me, doesnt update at at beyond 1. blizzard update comes up, and it goes fine now. Different install page comes up, and this always gives me the same response as the other 2.
I have still yet been able to install Heart of the Swarm. Is there nothing else I can try at all, that might work?

1. I would temporarily uninstall AVG. Disabling it is not always enough to stop it from interfering.

You'll want to use the AVG removal tool to ensure it's removed properly:

2. Try this:

1. Make sure that Windows is set to show hidden files.

Here's how to do that:

-Windows Vista/7

-Windows 8

2. Navigate to the C:\ProgramData folder and delete the folder.
3. Launch SC2 as an admin by right clicking on the launcher and selecting "Run as admin".

Let me know what happens.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information
I have also down that, Dankorii. However I just tried again just now, after uninstalling Starcraft 2 again this morning. It is now installing nicely and I have no idea why its like that now. But, thank you everyone for your help! While it may not have worked for me, it was worth the try. Thank you very much!

I'm glad to see the install is now working. Please feel free to post again if you have any other questions.
I'm available Monday through Friday from 11AM to 8PM Pacific Time
Support Contact Information

Join the Conversation

Return to Forum