Heart of the Swarm fps issue

Mac Technical Support
I used to run StarCraft II: Wings of Liberty with decent setting and getting between 60-100 fps, now that I got HOTS the performance has drop drastically! I'm getting between 20-30 fps with the same settings I used in WOL. Is any one else having the same problems?

I have the retina 15" Macbook Pro:

Processor 2.3 GHz Intel Core i7
Memory 8 GB 1600 MHz DDR3
Graphics Intel HD Graphics 4000 512 MB
Software OS X 10.8.2
When did first happen? The since there was only game data migration with HotS, it is still using the same client, so it would be weird if this just happened with no real patch implemented.

Have you done all the items listed in our StarCraft II Performance Troubleshooting support article?
It happened today when I installed HOTS, I tried the things mentioned in StarCraft II Performance Troubleshooting but it didn't fix the problems.
Ok. Well system requirements did change between WoL and HotS (patch 2.0.4), so the same settings you had in 1.5.x and below may not yield the same results.

Also, you mentioned a 15" MBP Retina. Are you using the 650M graphics card included in that? You only mentioned the Intel HD 4000.
I can confirm the same problems with the same solution. I noticed that my performance dropped to about 30 FPS at 1920x1100 with low settings on most maps, except Cloud Kingdom, which had ~170 FPS. After a repair everything seems to be uniform.

Model Name: iMac
Model Identifier: iMac11,3
Processor Name: Intel Core i5
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 12 GB
Processor Interconnect Speed: 4.8 GT/s
Boot ROM Version: IM112.0057.B01
SMC Version (system): 1.59f2
Hardware UUID: 0BBD1DEA-8187-57D4-A763-59CB5C307D7C
I am also having serious FPS issues. I noticed this in the beta and had hoped it would be fixed by the time it went live. I can barely play the game online...

The game suggests Ultra settings. Even on Low I get almost no FPS...

Model Name: Mac Pro
Model Identifier: MacPro3,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number of Processors: 2
Total Number of Cores: 8
L2 Cache (per Processor): 12 MB
Memory: 10 GB
Bus Speed: 1.6 GHz
Boot ROM Version: MP31.006C.B05
SMC Version (system): 1.25f4

AMD Radeon HD 6870:

Chipset Model: AMD Radeon HD 6870
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)

System Version: OS X 10.8.2 (12C60)
Kernel Version: Darwin 12.2.0
Boot Volume: Crucial M4 256
Boot Mode: Normal

Machine isnt exactly slow, however it is a 2008 3,1
I've seen a lot posts indicate resetting your SMC helps. Have we've tried that?

That should be listed in the low performance troubleshooting article, but I want to make sure that step is being done.
I have reset my SMC (unplugging for 15 seconds) with no success.
What FPS values are you getting? Did you try all the steps outlined in the StarCraft II Performance Troubleshooting article I listed earlier as well?
Currently having equal FPS results on 15" rMBP. Already tried resetting SMC and all the suggestions from the support article to no avail.

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32
Hardware UUID: A64E782B-2400-50BD-853F-1A27E84A9E8B
Try shutting down your Mac and restart it. I noticed a big drop in FPS from yesterday to today and that fixed the problem for me and I'm using a macbook pro.
Ok I believe I have fix my problem, I just uninstalled Starcraft and installed again and restarted my SMC. Not sure what the issue was but now I'm getting between 60-120 fps again.
I think it's a problem with mobile GPUs - running a 680m, and I constantly get dips to the low 40s during gameplay.

I ran WOL on my old laptop (285m) and had more consistent performance than this.
was having same issue on my retina 15". all better after SMC firmware update this morning.
I have reinstalled HOTS, reset SMC, updated OSX and am still dropping to 5fps in 3v3 games...

Any other suggestions as this isnt playable...
Id just like to say im having a similiar performance issue on my computer after updating as well.
2010 mac pro
12gb ram
5870 Radeon
I'm on a dingy 11" MBA. 2.0ghz i7, 8GB ram, intel 4000HD, 10.8.2. Lowest settings (for everything) and hitting about 17fps here as well. The cinematics don't really play very well for me either, the video skips a lot and the audio is out of sync.
Make sure you try the 10.8.3 update, it has updated drivers and fixes to wake from sleep fps issues as well for some models.
i have problems with fps my laptop windows is updated
my laptop is: Processor intel i5
memory : 6144mb ram
display memory : 1696
I run starcraft in low graphics but still i have low fps :( 50 fps pls help i run everything starcraft tropleshot...

Join the Conversation

Return to Forum