[Fixed] ~Corrupted cache files messing game~

Technical Support
Now then, i've been on the bug/tech issues forum for about a month or so trying to fix my problem. My problem was 2 corrupted cache folders that I couldn't play Quickmatches unless in a party, and portraits were messing up. After talking with 2 reps for 20-25 days, I finally found out what to do.

Go to the cache folders:

Win 7 and Vista
C:\ProgramData\Blizzard Entertainment\Battle.net\Cache.

Win XP
C:\Documents and Settings\All Users\Application Data\Blizzard Entertainment\Battle.net\Cache (I think)

When in there, look for corrupted folders. These folders may be messing up your game! I unfortunately couldn't remove them as it kept saying they weren't empty, so I did the next best thing. I moved it to the desktop :3. Cache folders and files are re-downloaded when you enter the game again, so if you move the corrupted folders to the desktop or somewhere safe.. When you log back on the slots that you took out of the cache folder will be fixed and you should be able to play again!

Notice: Patches do fix the game, but they may fix it to a certain extent that it corrupts cache files. If it does happen, just remove the corrupted cache folders and don't go through the trouble of having to figure it out, or spend a while without SC2.

~Hammy~ hope it helps! :3

I have a question about this method. How am I supposed to know wich folder is corrupted, among the 3289 of them?

Hope you have a solution beter than: move them all out.

By the way I'm having the portraits/achivements bug after 1.1.2 patch

Thanks in advance.
Related but not quite - I'm on Mac OS X, but was having the exact same problem and a very similar fix. I believe the problem is related to a bad patch, so I forced it to repatch the game.

For OS X (Leopard):
Go to /Applications/Starcraft II/Battle.net/
Move Battle.net-path.MPQ out of that directory.
Reopen Starcraft II and it should tell you that you need to repatch the game.

I don't believe it's any issue with the patch itself as the files are not different; however, since then my game has been working fine.
Arctaeus, what I had used was a take ownership program; that a tech support told me to use. It takes ownership of the files and tells you of corrupted ones. If you don't trust them, or have fear of being banned from "using 3rd party programs" such as that TO program. Just do this :3

takeown /f C:\ProgramData\Blizzard Entertainment\Battle.net\Cache

That will give you ownership of the file, but you still have no rights to delete it. Now you can run the cacls command to give yourself full control rights to the file (replace the text USERNAMEHERE with your WINDOWS login user name - case sensitive:

cacls C:\ProgramData\Blizzard Entertainment\Battle.net\Cache /G USERNAMEHERE:F


Use this option if the top one doesn't load, if you use Vista or some other operating system that doesn't have the cache in these locations; then just replace the "ProgramData"

takeown /f "C:\ProgramData\Blizzard Entertainment\Battle.net\Cache"

takeown /f C:\ProgramData\Blizza~1\Battle.net\Cache


cacls "C:\ProgramData\Blizzard Entertainment\Battle.net\Cache" /G USERNAMEHERE:F

cacls C:\ProgramData\Blizza~1\Battle.net\Cache /G USERNAMEHERE:F


If that doesn't work, then you can always just delete the cache folder. It will come back as soon as you log on.
+Liked. Waiting for sticky.
I'm hoping it gets stickied, as many peoples problems lie within the cache folders.

Edit: As if you re-install and it doesn't help your game; then it lies within the caches. Corrupted cache folders do not get overwritten when playing the game.. And corrupted cache files are caused when a patch messes 1 detail up.
so to clarify all of this basically the lazy way instead of looking for corrupted files u said we can just delete the cache folder? and it will come right back when logged in?
How would I tell which files are corrupt? I tryed what you said to Arctaeus but it wont work.

Could there be a type error?
Palace, are you on Vista?
i tried doing this and got worse


now i CANT remove the cache file at all T_T
Aha! You see; that's the problem. You had a corrupted cache file and it was making your game mess up. Can you drag the file? If you can, move it to the desktop or somewhere and name it "Corrupted". I haven't been able to figure out how to delete those types of folders that are corrupted, so if you move it you should be able to play.

Edit: Corrupted cache files are the main source of gameplay problems, and a corrupted cache file can usually happen right after a patch. I recommend, that you use a scanner like Avast free scanner to scan the cache and find the correct file/folder.
No I use Windows XP
I think for Win XP, the cache files are located in:

C:\Documents and Settings\All Users\Application Data\Blizzard Entertainment\Battle.net\Cache

If you go there, and don't want to do all the complicated steps, just delete the files. They'll come back when you restore the game :3.

Let me know how it goes.
So I delete all 130?

Sorry 257 files

Nope, didn't work. I started the game and I got a message saying Achievements have been disabled then another saying they were restored but took forever to load and I noticed that I couldn't access Single Player so I went to Continue Campaign on the Home Page and exited but now I am back to where I started with this stupid problem.

Can't access my achievements, rewards, and my gamer score is still shown as 0000

I will also add that achievements aren't showing for me even in the Campaign and Challenges

I want to change my portrait :(
I found which cache folder is corrupted but how do i move it or get ride of it?
If it does happen, just remove the corrupted cache folders and don't go through the trouble of having to figure it out, or spend a while without SC2.
First of all thanks Hammyobob, for this solution, altough it didn't work for me. :((

I did deleted the cache folder--after making a backup of course :)-- and the bug became a little more worse; I was already able to see my portrait, and that of others, but couldn't change it. Upon deleting the cache folder I got back to where I started.... with a little more in-game lag. :(

Thanks anyway and hope this method works for someone, while Blizzard fixes it.

Peace... or war.... In Starcraft of course. 8D
I try to delete the folder and it won't let me saying the directory is not empty. I also tryed to move it move the file but when i do it dosn't move, it stays in the same folder. What am i doing wrong?
Marc, first get avast and scan the cache folder to make sure there are corrupted files in there, as if it's saying the directory is not empty.. That means a corrupted folder in there.

You can download the scan off google, then after the scan uninstall it from your computer if you don't want it. After the scan, it will tell you what folders are corrupted. You can then just move those folders. Arctaeus, I didn't mean for you to delete the whole cache folder :3. I haven't tried that yet. I just individually moved the two folders, and everything worked fine.

Join the Conversation

Return to Forum