'Waiting for Server' 'Surrender'

Mac Technical Support
Prev 1 4 5 6 9 Next
I would like to add that this: http://us.battle.net/sc2/en/forum/topic/8197761877 seems related.
Other than a troll comment that was spammed and deleted...

Has there been any more looking into this?
I haven't had any problems with this since the patch. Anyone else?
My sc2 was working perfectly fine in Toronto Canada, until I moved to NY for College.
I talked to my new ISP Time Warner and they are convinced it's not their problem, they even sent a technician to my place and they said it's not their problem.
The problem is when I start a new game the Waiting for Server screen popups up within the first 10 seconds, and subsequently lags out.

Can somebody please help me?

BTW everything else works fine, I can watch videos, streams, check email, play live online chess, etc.

Looking forward to some help!
i have this issue a lot too. After about 20-30 minutes i will get this screen and have to force shut-down.

This is really annoying and support is no help. I feel that this is an error on their side.

FRUSTRATING!!!! I never lose but the disconnect counts as a loss!
Edit: Didn't realize this was the mac forum. My issue below is PC.

Same here. Only started with the last patch. Played for a month straight before that with no issues. Since the last patch, every single game ends in "Waiting for Server." It happens at random times throughout the game. Average is about 5 minutes. While it is happening, the internet connection remains stable (Skype, etc.). I was even talking to a friend through in-game voice chat once while it happened and we never lost the connection.
i have tried doing a traceRT and it connects despite the WAITING ON SERVER crap!!!

Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.


Tracing route to over a maximum of 30 hops

1 2 ms 2 ms 8 ms
2 9 ms 7 ms 7 ms
3 9 ms 18 ms 11 ms 173-219-249-68-link.sta.suddenlink.net [173.219.
4 41 ms 38 ms 40 ms 173-219-248-179-link.sta.suddenlink.net [173.219
5 51 ms 52 ms 49 ms 173-219-243-24-link.sta.suddenlink.net [173.219.
6 49 ms 49 ms 49 ms
7 107 ms 106 ms 108 ms cr1.dlstx.ip.att.net []
8 112 ms 115 ms 119 ms cr2.nsvtn.ip.att.net []
9 106 ms 108 ms 108 ms cr1.cl2oh.ip.att.net []
10 109 ms 107 ms 106 ms cr2.cl2oh.ip.att.net []
11 108 ms 106 ms 107 ms cr2.phlpa.ip.att.net []
12 106 ms 102 ms 104 ms gar1.pitpa.ip.att.net []
13 109 ms 107 ms 110 ms
14 109 ms 111 ms 156 ms mdf001c7613r0004-gig-12-1.nyc3.attens.net [63.24
15 * * * Request timed out.
16 * * * Request timed out.
17 * * * Request timed out.
18 * * * Request timed out.
I seem to be able to play an entire game initially while the second game is interrupted by the "waiting for server" screen in the first 5 seconds of the match.

I've been experiencing this same issue off and on since March. Doesn't seem to be any particular pattern to it, some days I'll play several games without a problem, other days it happens nearly every single match (but interestingly, only once during any particular match; I never get the "waiting for server" message twice during a match, assuming I don't get dropped first).

Definitely not an internet connection issue; I've been on Skype with teammates in the past, I'll be frozen at the "waiting for server/surrender" message screen while experiencing no audio drops in Skype.

I live in the southeastern US area, if that matters in terms of the Blizzard servers I'm connecting to.

Very annoying.
Been happening to me the last several days and hasnt happened in the last few years. What's going on??

Mac OSX Mavericks 10.9
intel 2.7ghz 64bit ivy bridge
Come on guys, this "thread" has been here over 8 months now… what kind of a support is that ?
I payed a game I can't play on my Mac, it's simply unusable. Don't think I'll buy the 3rd expansion if no solution arises, I'm kind of disappointed, 8 months is too long for on online game.
WoL worked fine. Since HotS, it keeps disconnecting, so it's not my mac the problem, it's your game. Fix it.
OMG, I am getting the same thing too, really frustrating! It largely due to the internet connection problem, however, the program has no retry button, Damn it!
Yeah, agree, what kind of support is this really?
Tons of people are complaining about the waiting for server - surrender problem yet no fix.

This poblem never happened in Wings of Liberty, must be some bug with HoTS.

To the guys in Blozzard, if you don't want to loose clients, then please do something about this.
has this issue been resolved yet? noticed that thread started for months but there's no solution to this. is anyone following up for a fix?
...I recently return to playing sc2 to find my games being auto dced by the server. This is tragic. It just seems like Blizzards been hiring monkeys to maintain their servers these days. Please put some more effort into these things, unless you want to lose your casual players for good.

-From a long time blizzard fanboy
Same problem, same frustration. After not playing SC2 for a while I come back and this. I can't even play against the AI. I am playing WoL not HotS. I am not in a Mac, google brought me here. My system is: i7, GTX 675M, 16 gb ram, 1.5 tb hd, win 8. This doesn't seem to be OS specific.
I would like to BUMP this as I just purchased HoTS the other day and have not been able to play a single game (both vs AI and players) besides Campaign sense installation... My internet is not the issue as I can browse, stream, and play WoW no problem. This issue even occurs when I am hardwired. Seems to me this post was created nearly a year ago, and Blizzard still has no legitimate "fix"... that's called being lazy fellas.
same exact thing is happening to me fml... its been going on for a week now I have no idea what the issue could be. I'm thinking it may have been the recent patch??

Join the Conversation

Return to Forum