Problem with Toast Notifications

Mac Technical Support
Is there anyone out here, who has the same problem? While playing SC2 on Mac OS X 10.8.3 and current patch (2.0.6), toast notifications aren't shown. While on Windows, it works, but only there. I refuse to install Windows just to see the notifications.

It's somehow strange. I checked my settings and yes, it's enabled, timer set to 5 seconds.

When I finish a custom game or VS A.I. and gain a level upgrade, then - and only then - a toast notification is displayed. While playing campaign, none is displayed.

And like I said, it occurs only on OS X. This problem seems to exist since the patch

Is there no fix? It's annoying because I don't know when I earn an achievement while playing. I have to navigate to the Achievements screen to see what I got and what not.

Come on...there has to be a fix....
I've also had the same problem and have tried these solutions which were posted in other forums:

1) In the Social tab under OPTIONS, try Restore Defaults, restart starcraft 2, and upon unlocking another achievement see if it pops up.
2) If it's still broken, try "Restore Default" to every tab in OPTIONS, restart Starcraft2, and see if that works.

Neither of those worked for me BUT THIS WORKED:

Clearing your Cache
1. Navigate to Mac HD/Users/Shared/Blizzard/
2. Move the folder to the trash.
3. Empty the Trash.
4. Launch Starcraft II

Check out the forum here:
Hm, I was under the assumptions that Blizzard never reenabled achievements toasts since launch (they disabled them cause the servers where being hammered). Regardless, I too haven't been seeing them.
Blizzard any ETA on when achievement toasts will be available again?
I also saw a the achievement problem noted in a recent (maybe within 2 ago) patch, AND upon playing on online there was a period of a few hours where they did a routine maintenance check, noting that they were restarting the achievement service.

This should have resolved any issues with it. So you're still having problems?

Like I said, I cleared my cache ^^ (above response), and everything was fine after that. The patch came later after the problem had already been fixed.

Let me know if the cache works!?

Join the Conversation

Return to Forum