Blizzard launcher crashes on opening

Mac Technical Support
Whenever I try to run starcraft 2 the blizzard launcher begins to open but then I get this error report and the whole thing crashes. It opens and then says updating but then crashes while trying to do it.
Im running on OSX 10.6.8 and im not sure if this maybe has something to do with the problem or if it a completely different issue
I have the crash log here if that would help
I too have this problem. There's some files you can delete in one of the temp folders, but that doesn't remedy the problem for very long, as it seems to come back every time.
Unless you fixed it, I would post the error report so people with a better understanding can take a look at it and possibly help you solve the problem.
Please post the crash, so we can check it out.

Also, did you try some stuff from our StarCraft II Lockups and Crash Errors page?
I get this crash error..

Blizzard Launcher.exe: (build 1995)

Exe: C:\ProgramData\\Client\Blizzard Launcher.1995\Blizzard Launcher.exe
Time: Aug 29, 2013 12:19:14.462 AM
User: Andromeda

This application has encountered a critical error:

ERROR #1 (0x13370001) Fatal Exception
Program: C:\ProgramData\\Client\Blizzard Launcher.1995\Blizzard Launcher.exe

The instruction at "0x016769CB" referenced memory at "0x00000000".
The memory could not be read.

Project: 19140301
Build: 1995
I had the same problem like IIIIIIIII on the last post. The solution is: follow this link and use the software which detects missing and outdated drivers. Install the ones shown, (those are only the ones that you need, the drivers you have up to date are not shown there) reboot and problem solved.
Hey, what file is this? If I can at least get it to work half the time its better than not being able to play at all.

Join the Conversation

Return to Forum