Game exits to launcher after launch. (Fixed)

Technical Support
As the title says, the game refuses to launch. I click Play, it loads, it gets to the title screen, freezes for a second, closes, and the launcher just pops right back up. I've tried running as an administrator, playing around with my firewall settings, and changing to windowed mode (it's works for other things for me).

When I run the repair tool I get:

An unknown error (2231) has occurred when attempting to download data.

I have yet to try reinstalling, as it takes hours to download, but if there's no other easier suggestions, I may just have to try.

I'm running the Vanilla game on a standard edition account. I can post system specs if needed, but it was running just fine last week.

EDIT: The launcher will no longer get past the Initializing stage.

EDIT 2: I tried launching via SC2Switcher.exe and had the same thing happen, but this time when it quit to the launcher, it went past Initializing and started updating. I guess if this happens to you, try that.

EDIT 3: May have been my firewall changing my settings. I feel slightly like a bit of a moron now.
The same thing is happening to me.

I tried everything from battlenets support
https://us.battle.net/support/en/article/streaming-errors

I also attempted to repair via repair tool but the same thing is happening to me.
Charles, I would try these suggestions too. Please let us know how it works out, and we can work from there.
________________________________________________
Rate me! https://www.surveymonkey.com/s/Velnrak

Join the Conversation

Return to Forum