HOTS patch killed my command+click

Mac Technical Support
I was playing Heart of The Swarm, beat the campaign, and was playing AI matches for a couple of days, then the patch came along and kind of broke my wings.

The biggest problem is that I can't command units to gather resources at a new location because I can't command+click on the mineral fields. The other problems are more annoyances as I am now forced to use key commands to build my base and units, and navigating the units around a map.

at first I thought it was the batteries on my keyboard, so I changed them. Still no different.

Please help! I'd much rather get more than < month usage of the game.

I'm currently running iOS 10.7.5
Does command-click work anywhere else in the game as well?
no. it just ends up turning into a regular click. Say if I were to try to send units to attack something, I would just end up selecting the enemy unit.

Do you have any custom keybinds setup?

I would try to reset any keybinds you have first, to ensure another action is not stealing it.

Also, you're not running programs like photoshop when doing this, right? I remember PS was stealing some event entries.

Can you also post your full system specs?

Obtaining System Information
    1. Hold the 'Option' Key and choose System Profiler/Information from the Apple Menu.

    2. Copy the information from the following sections:
  • Hardware (remove the Serial Number line)
  • Graphics/Displays
  • Software (remove the Computer Name and User Name lines)
messed around with gameplay options, and it works now. Thanks for your time.

Join the Conversation

Return to Forum