Custom Maps Won't Show or Download

Mac Technical Support
When I go to the Custom Games section, and look for open games or try to browse maps and create my own, I'm stuck with the spinning recticle in the center of my screen. Maps don't load on screen.

Yesterday they were loading but when I would try to create a game, my screen would show that I was downloading the map, but it never finished (I had friends in my group who downloaded the map in 5-10 seconds).

So far, I've used the Terminal Flush, deleted my cache, and last night I uninstalled and reinstalled the game. Still no luck.

Please let me know what I can do to fix this issue. It seems like a server connectivity issue of some kind, but I have no firewalls or anything that I can imagine would be causing this problem.


EDIT: I also just remembered that watching Replays does not work either (I experience the same loading issue that I described above - the rest of my group would load a replay and watch it while I remained stuck in menus with a "Downloading..." status).

EDIT 2: I can now no longer see matchmaking of any kind. Only thing that works is campaign... Please help!!
Something is blocking the game from downloading stuff.

Do you have any security apps on your Mac? Try closing background apps to see if this helps.
I have the same problem. The spinning circle never gives way to a list of maps.
This has been an ongoing problem. Also, the need to design this in such a way that you do not have to turn off firewalls or security. That is not a realistic solution nowadays. I really think that Blizzard needs to get away from parts of the game running online. Even if you want to play by yourself against the computer you have to be online.
I have this issue with trying to load maps for a custom game quite often, left with the spinning circle. Starcraft 2 on my computer is already set to bypass the firewall on any type of network I'm connected to and my virus/malware/security software is set to ignore it. Turning off both the firewall AND the virus/malware/security (which I do not recommend) has no effect on this spinning circle.

SOMETIMES, closing the game entirely and reopening it will allow me to load maps, but my bookmarked maps page almost never loads. This has been an issue for me for a long time.
I guess they have no real solution for this.

I have this issue also, and it's been ongoing for awhile. Some times it works fine, other times it does not. I have my firewall off and absolutely no security software running. So I some how doubt this is the solution.
Don't know if this is just a coincidence or not but I was having another problem as well with the video freezing and one solution for that was to uninstall the launcher I did that and now the custom maps are working for me again.
My Mac freezes when I go to Custom Games. They need to fix this.
Having the same issue, custom maps will not load on latest yosemite 10.10, firewall is off. This is on a fresh install of the OS no other programs installed.
Wow, a lot of us seem to have this problem. Maybe Blizzard needs to fix this. I also have Yosemite/Firewall off etc, and I have to force quit by holding down the power button every time now.

This would not bother me as much except that creating custom games is my favorite part of SC2...
Same issue here. Under the Custom Games heading, I cannot view my list of bookmarked maps, browse maps, or view open games. Just the endless spinning circle.

This issue is intermittent. Just a couple days ago, I played several games with no problem. Nothing has changed in the interim. However, just as an aside, the map browsing here has always been slow. It just usually doesn't fail to load whatsoever.

Edit: I'll also confirm that closing the game and reopening seems to help when this occurs.
To any 1 still stuck with this problem this is what helped for me. When i installed sc2 i chose a different destination and when b net instaled i didnt change it, so i went and cut bnet from my program files and placed it in the same folder as the sc2 destination that i chose on instalation. hope it helps
seriously this is why this game is dying....this problem has been there since 2013 and still didnt fix it ....
+1 the spinning circle lasts forever, maps never show. Don't have anything that could be blocking it as far as I know. SC2 is accepted through any firewall I've got
+1 Same here, It's 2016... c'mon.
Same issue on my iMac and Macbook Air.
+1 still messed up.
i have the same problem! can you guys please give us some help?
MAC USERS: this worked for me.

1. System Preferences
2. Security & Privacy
3. Privacy tab
4a. Click the lock icon in the lower left of the window to unlock if needed
4b. Check SC2 under "Allow the apps below to control your computer"

Join the Conversation

Return to Forum