Game Not downloading

Technical Support
I do decided to start playing starcraft again, to my surprise I put in the cd downloaded the client and the download has been at 0 percent for like an hour. I deleted the game again and reinstalled many times but with the same result. I also downloaded the client right from the website here and it is the same result. There is no downloading speed or anything.

What should I do? I am on a constant interenet connection so scratch that.
Same problem here...
Blizzard it says "Can't connect because of interent connection" yet other people in the house hold was allowed to download sc2 and I wasn't.

I disabled the firewall so that wasn't the problem.

It wasn't the internet because other people in the house hold download it without a problem.
I don't know if this will help but it helped other people with a downloading issue.

Went to Control Panel,
network and internet,
internet options,
LAN settings,
and disabled "detect settings automatically. Hope that helps.
Tried it, still doesn't work :/
Yep can we get a blue on this thread?
Geminieclips solution solved my problem, got to 50.1% downloaded and it would not resume. Followed his solution and we are now past 50.1%
The problem is when Gatelo tries to instal the "Starcraft 2 setup" It won't start because it says internet connection is busy, which isn't true because myself and xthilio solved it no problem.
So it has been a few days just want to say this is still a problem.

It just says "An internal error has occured" We can not even use the starcraft repair option.

Join the Conversation

Return to Forum