Very low framerate after applying 2.0.7 patch

Mac Technical Support
Prior to the 2.0.7 patch, I had my graphics set to mostly "high" across most of the options and I was able to get around 30 FPS in a multiplayer game. Right after applying the patch I noticed that the main menu screen seemed slow, so I checked and found out I was only getting 9-10 FPS. I went into a game and immediately I could tell I was running slowly. I even got the message that I was slowing down the game.

After the game, I turned everything down to medium and started another game. It improved a bit, but according to the cmd+option+f FPS display, I was still only getting around 20 FPS, and it was introducing very noticeable lag on my end, especially placing buildings and selecting units. I just tried on low settings and got 59-60 fps (using vertical sync), but when I go to the standard medium settings, I only get 19-20 fps. Before, I was getting 29-30 fps on generally "high" settings.

I have a 2012 model quad core i7 macbook pro with the fastest graphics card available and 8GB RAM. One thing to note is that I usually play the game on a 24 inch external monitor connected via a displayport to HDMI connector. I will try the game using the laptop monitor as well. (Using the laptop lcd, the game has always performed faster due to the decreased resolution, but again, I almost always use the external display and it's never been a problem for performance.)

Essentially, I'm experiencing a significant drop in performance without making any changes other than applying the 2.0.7 patch.

Any ideas?

System info:

Model Name: MacBook Pro
Model Identifier: MacBookPro9,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3682
gMux Version: 1.9.23
IPS236 :
Resolution: 1920 x 1080 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: SerialNumber
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Television: Yes
Make sure you are updated to 10.8.3, and have newest firmware. after doing so, do an SMC reset then try. it's possible you just need to clear out your SMC.
I am at 10.8.3, I will try the SMC reset and report back.
That fixed it. I can play on high settings at 60 fps now.

Join the Conversation

Return to Forum